This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1003018 - Switchyard subsystem should be offilne when connection settings are invalid
Switchyard subsystem should be offilne when connection settings are invalid
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- SOA 6 (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ---
: JON 3.2.0
Assigned To: kconner
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 09:46 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 03:04:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-08-30 09:46:38 EDT
Description of problem: Currently user has no way to find out that connection settings for SwitchYard subsystem are correct or not. 


Version-Release number of selected component (if applicable):
RHQ 4.9-master SwitchYard plugin master

How reproducible: always


Steps to Reproduce:
1.create rhqadmin:rhqadmin mgmt user for your SOA instance
2.import it to JON (import must work out-of-box)
3.go to SwitchYard's connection settings and change username to foo

Actual results: SwitchYard subsystem stays UP


Expected results: SwitchYard subsystem must appear DOWN, because when connection settings are wrong, it cannot detect any new applications or push metrics to JON server.


Additional info:
Comment 1 Libor Zoubek 2013-08-30 10:09:14 EDT
It looks like switchyard plugin does not respect connection settings changes.

It does respect it when: I change it to wrong settings, then I restart agent. Then SwitchYard subsystem is DOWN, when I update settings to correct ones, subsystem goes up.

In other cases - when I change from correct to incorrect settings, it does not have any effect.
Comment 2 Libor Zoubek 2013-10-04 03:04:23 EDT
This is no longer valid for JON 3.2.ER2 because switchyard plugin was migrated from MBeans to DMR, so there are no additional connection settings for switchyard subsystem anymore.

Note You need to log in before you can comment on or make changes to this bug.