Bug 1003024 - Signal process instance request via REST API requires both the XML body and form parameters
Signal process instance request via REST API requires both the XML body and f...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Marco Rietveld
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 10:01 EDT by Ivo Bek
Modified: 2016-09-20 01:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-08-30 10:01:19 EDT
Description of problem:

There is no need to send any XML body for signal process instance method since all the required params are send within form. Now it's not possible to send the signal request because I cannot fulfill the Consumes(xml) requirement.
Hint: It should be enough to remove the Consumes annotation. https://github.com/droolsjbpm/droolsjbpm-integration/blob/master/kie-remote/kie-services-remote/src/main/java/org/kie/services/remote/rest/RuntimeResource.java#L119

I use following request with the form parameters.

ClientRequest restRequest = createRequest(address);
restRequest.accept("application/xml");

restRequest.formParameter("eventType", eventType);
restRequest.formParameter("event", event);

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Marco Rietveld 2013-09-03 09:54:48 EDT
Fixed with this commit: 

https://github.com/droolsjbpm/droolsjbpm-integration/commit/b366d3d12b81a779c4492443fcb2ad469afefbbf

Please set the milestone and set to MODIFIED. 
Thanks!
Comment 6 Ivo Bek 2013-10-15 07:39:19 EDT
Verified in BPMS 6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.