This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1003092 - The RHEV-toolsSetup_3.3_5.iso is not installing sound drivers.
The RHEV-toolsSetup_3.3_5.iso is not installing sound drivers.
Status: CLOSED DUPLICATE of bug 1002695
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: distribution (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Roy Golan
virt
: Regression, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 14:26 EDT by Bill Sanford
Modified: 2013-09-18 04:06 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 03:25:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-08-30 14:26:46 EDT
Description of problem:
I have installed RHEV-M (is12) and have created a Windows 7x64 VM. The tools-ISO is not installing the sound drivers on the guest.

Version-Release number of selected component (if applicable):
rhev-guest-tools-iso-3.3-5.noarch.rpm

How reproducible:
100%

Steps to Reproduce:
1. Create VM.
2. Install RHEV-toolsSetup_3.3_5.iso on the guest.
3.

Actual results:
No sound drivers are installed.

Expected results:
Sound drivers are installed.

Additional info:
Comment 2 Lev Veyde 2013-09-01 05:11:04 EDT
Windows Guest Tools are not supposed to install sound device drivers. These normally come from the OS itself.

Please note that Server VMs don't have sound device, only Desktop VMs have one.
Please make sure that you chose to create a Desktop VM, not a Server one.
Comment 3 Itamar Heim 2013-09-01 08:33:51 EDT
lev - just a btw, in 3.3, we changed this and you can choose audio device for any vm.
Comment 4 Bill Sanford 2013-09-03 11:28:11 EDT
This is a desktop VM.
Comment 6 Bill Sanford 2013-09-09 08:50:55 EDT
qemu     24487  0.9 13.3 1594244 1074156 ?     Sl   Aug30 130:35 /usr/libexec/qemu-kvm -name Win7x64 -S -M rhel6.4.0 -cpu Opteron_G3 -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -uuid b0375f21-ae13-4797-a848-0ffa18559233 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.4.0.4.el6,serial=8AA6FB90-56CB-1020-0519-153434000000,uuid=b0375f21-ae13-4797-a848-0ffa18559233 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Win7x64.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2013-08-30T20:09:46,driftfix=slew -no-shutdown -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x6 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/rhev/data-center/5849b030-626e-47cb-ad90-3ce782d831b3/e20f0fd4-46a4-49db-bf9b-2280969dac08/images/053ffe6e-89c5-4c34-bee1-eb02367ee320/af4af240-ca7c-4ba8-a5b7-4ca48253f7f6,if=none,id=drive-ide0-0-0,format=raw,serial=053ffe6e-89c5-4c34-bee1-eb02367ee320,cache=none,werror=stop,rerror=stop,aio=native -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=26,id=hostnet0,vhost=on,vhostfd=27 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:bf:72:a1,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/b0375f21-ae13-4797-a848-0ffa18559233.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/b0375f21-ae13-4797-a848-0ffa18559233.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice port=5900,tls-port=5901,addr=0,x509-dir=/etc/pki/vdsm/libvirt-spice,tls-channel=main,tls-channel=display,tls-channel=inputs,tls-channel=cursor,tls-channel=playback,tls-channel=record,tls-channel=smartcard,tls-channel=usbredir,seamless-migration=on -k en-us -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -device AC97,id=sound0,bus=pci.0,addr=0x4 -chardev spicevmc,id=charredir0,name=usbredir -device usb-redir,chardev=charredir0,id=redir0 -chardev spicevmc,id=charredir1,name=usbredir -device usb-redir,chardev=charredir1,id=redir1 -chardev spicevmc,id=charredir2,name=usbredir -device usb-redir,chardev=charredir2,id=redir2 -chardev spicevmc,id=charredir3,name=usbredir -device usb-redir,chardev=charredir3,id=redir3 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x8
Comment 7 Lev Veyde 2013-09-09 11:06:36 EDT
It seems that in RHEV 3.3 the type of audio device that is created for some types of OS had changed, and that is what causing this issue.

Under RHEV 3.2 normally the audio device created for Desktop VMs for Windows 7 OS is of HD Audio type (no audio device was created for Server type), and it has a built-in driver in the OS.

Unfortunately it doesn't seem to have the driver for AC97 device that i.e. Windows XP installs without any issue.

Under RHEV-3.3 the default seems to be now the AC97, unless "Other" OS is chosen.
Comment 8 Lev Veyde 2013-09-09 11:28:05 EDT
The fix for this would require to modify the default properties of VMs to match the ones of RHEV 3.2, as these seemed to work fine.

Moving the BZ to rgolan from the infra team.
Comment 9 Bill Sanford 2013-09-12 15:57:34 EDT
I installed RHEL 6.5 and added a Windows XP VM. I noticed that the default sound driver in the Virt-manager was still ich6 after I had added the SPICE display and qxl driver and then installed the rhev-guest-tools-iso-3.3-5.noarch.rpm on the guest.

Until RHEL 6.5, I never had to worry about selecting sound drivers after I installed a VM that uses SPICE.
Comment 10 Roy Golan 2013-09-17 03:25:48 EDT

*** This bug has been marked as a duplicate of bug 1002695 ***

Note You need to log in before you can comment on or make changes to this bug.