Bug 1003112 - [abrt] yum-3.4.3-106.fc19: yummain.py:235:main:UnboundLocalError: local variable 'return_code' referenced before assignment
[abrt] yum-3.4.3-106.fc19: yummain.py:235:main:UnboundLocalError: local varia...
Status: CLOSED DUPLICATE of bug 867389
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:04c0793b6240136b14718b10e89...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 16:17 EDT by Fred R. Beck
Modified: 2013-09-02 03:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 03:23:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.24 KB, text/plain)
2013-08-30 16:17 EDT, Fred R. Beck
no flags Details
File: environ (2.11 KB, text/plain)
2013-08-30 16:17 EDT, Fred R. Beck
no flags Details

  None (edit)
Description Fred R. Beck 2013-08-30 16:17:02 EDT
Version-Release number of selected component:
yum-3.4.3-106.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /bin/yum -y install http://sourceforge.net/projects/postinstaller/files/fedora/releases/19/i386/updates/wine-silverligh-1.6-3.fc19.i686.rpm
executable:     /bin/yum
kernel:         3.10.9-200.fc19.i686.PAE
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
yummain.py:235:main:UnboundLocalError: local variable 'return_code' referenced before assignment

Traceback (most recent call last):
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 235, in main
    if type(return_code) == type((0,)) and len(return_code) == 2:
UnboundLocalError: local variable 'return_code' referenced before assignment

Local variables in innermost frame:
exFatal: <function exFatal at 0xb6fa42cc>
resultmsgs: [u'Error getting repository data for /wine-silverligh-1.6-3.fc19.i686, repository not found']
args: ['-y', 'install', 'http://sourceforge.net/projects/postinstaller/files/fedora/releases/19/i386/updates/wine-silverligh-1.6-3.fc19.i686.rpm']
verbose_logger: <logging.Logger object at 0xb6f9af4c>
unlock: <function unlock at 0xb6fa4304>
base: <cli.YumBaseCli object at 0xb6f9af6c>
result: 1
e: RepoError()
exPluginExit: <function exPluginExit at 0xb6fa4294>
exUserCancel: <function exUserCancel at 0xb7049c6c>
logger: <logging.Logger object at 0xb6f9aeec>
exIOError: <function exIOError at 0xb6fa425c>
rpmdb_warn_checks: <function rpmdb_warn_checks at 0xb6fa433c>
Comment 1 Fred R. Beck 2013-08-30 16:17:07 EDT
Created attachment 792314 [details]
File: backtrace
Comment 2 Fred R. Beck 2013-08-30 16:17:10 EDT
Created attachment 792315 [details]
File: environ
Comment 3 Zdeněk Pavlas 2013-09-02 03:23:20 EDT
Fixed in commit cf47b025b12ad53bd99a6091d48822003d5e95be introduced to fix related BZ 867389.

*** This bug has been marked as a duplicate of bug 867389 ***

Note You need to log in before you can comment on or make changes to this bug.