Bug 1003115 - mariadb-libs has a file conflict with community-mysql-libs
mariadb-libs has a file conflict with community-mysql-libs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 16:34 EDT by Bruno Wolff III
Modified: 2013-11-18 02:17 EST (History)
3 users (show)

See Also:
Fixed In Version: community-mysql-5.6.14-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 02:17:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 999589 None None None Never

  None (edit)
Description Bruno Wolff III 2013-08-30 16:34:47 EDT
Description of problem:
Transaction check error:
  file /etc/my.cnf from install of mariadb-libs-1:5.5.32-11.fc21.i686 conflicts with file from package community-mysql-libs-5.5.33-1.fc20.i686
Comment 1 Michal Jaegermann 2013-09-01 15:03:23 EDT
This is the single difference between an already present /etc/my.cnf and a file supplied by mariadb-libs:

--- /etc/my.cnf	2013-08-20 09:40:12.000000000 -0600
+++ my.cnf	2013-08-29 08:06:54.000000000 -0600
@@ -11,3 +11,3 @@
 [mysqld_safe]
-log-error=/var/log/mysqld.log
+log-error=/var/log/mariadb/mariadb.log
 pid-file=/var/run/mysqld/mysqld.pid

with this proviso that mariadb-server-5.5.32-11 actually supplies /var/log/mysqld.log -> /var/log/mariadb/mariadb.log link (before that failed update /var/log/mysqld.log is a file, owned by mariadb-server, and this looks like a possible trouble spot if mysqld.log happens to be non-emtpy).
Comment 2 Honza Horak 2013-09-02 11:42:58 EDT
Thanks for reporting, guys.

This is quite complicated issue, because both packages by default read only /etc/my.cnf and other files under /etc/my.cnf.d/ are read only after !includedir statement is used in /etc/my.cnf explicitly. So generally, having two non-conflicting /etc/my.cnf config files in two separate packages seems to be a need. So this file actually needs to be the same in both packages (or moved to the separate package, while using proper requirements, but the result would be the same).

So the fix I'm going to apply will be to keep only general settings for all MySQL implementations in /etc/my.cnf, while moving MariaDB-specific settings into specific sections like [mariadb] or [mariadb-5.5], which were introduced especially for such purposes.

(In reply to Michal Jaegermann from comment #1)
> with this proviso that mariadb-server-5.5.32-11 actually supplies
> /var/log/mysqld.log -> /var/log/mariadb/mariadb.log link (before that failed
> update /var/log/mysqld.log is a file, owned by mariadb-server, and this
> looks like a possible trouble spot if mysqld.log happens to be non-emtpy).

We're aware of possible issues (tracked down in bug #999589) but we believe all common cases should work fine and advantages will surpass issues. Of course, this will need to be mentioned in release notes. For more info see https://bugzilla.redhat.com/show_bug.cgi?id=999589#c1
Comment 3 Honza Horak 2013-09-03 11:40:35 EDT
New builds community-mysql-libs-5.5.33-2.fc20 and mariadb-libs-5.5.32-12.fc20 are not in conflict any more:

# rpm -q mariadb-libs community-mysql-libs
mariadb-libs-5.5.32-12.fc20.x86_64
community-mysql-libs-5.5.33-2.fc20.x86_64
Comment 4 Michal Jaegermann 2013-10-10 18:02:49 EDT
On rawhide there is still:

Transaction check error:
  file /etc/my.cnf from install of community-mysql-libs-5.6.14-1.fc21.x86_64 conflicts with file from package mariadb-libs-1:5.5.32-12.fc21.x86_64
This is a build from "Thu 10 Oct 2013" for community-mysql-libs.
Comment 5 Honza Horak 2013-10-11 07:32:17 EDT
Thanks for pointing to that. It's fixed again with community-mysql-5.6.14-2.fc21.
Comment 6 Mattia Verga 2013-11-15 14:02:25 EST
Seems to be a problem again in F20:

Error: community-mysql conflicts with 1:mariadb-5.5.33a-2.fc20.x86_64
Error: mariadb conflicts with community-mysql-5.5.34-1.fc20.x86_64
Comment 7 Honza Horak 2013-11-18 02:17:17 EST
(In reply to Mattia Verga from comment #6)
> Seems to be a problem again in F20:
> 
> Error: community-mysql conflicts with 1:mariadb-5.5.33a-2.fc20.x86_64
> Error: mariadb conflicts with community-mysql-5.5.34-1.fc20.x86_64

Actually, this conflict is expected and defined explicitly. The only packages that are expected to be installed in parallel are mariadb-libs and community-mysql-libs packages, which seems to work fine:

$ rpm -q community-mysql-libs mariadb-libs
community-mysql-libs-5.5.34-1.fc20.x86_64
mariadb-libs-5.5.33a-2.fc20.x86_64

Note You need to log in before you can comment on or make changes to this bug.