Bug 1003122 - PackageKit-Qt should depend on PackageKit
PackageKit-Qt should depend on PackageKit
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit-Qt (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Reopened
Depends On:
Blocks: F21BetaBlocker
  Show dependency treegraph
 
Reported: 2013-08-30 18:17 EDT by Orion Poplawski
Modified: 2014-10-17 04:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: PackageKit-Qt-0.8.9-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-23 00:34:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-08-30 18:17:26 EDT
Description of problem:

PackageKit-Qt is pretty useless without PackageKit.  It should require it.

Version-Release number of selected component (if applicable):
PackageKit-Qt-0.8.8-1.fc19.x86_64
Comment 1 Fedora Update System 2014-09-04 11:53:14 EDT
PackageKit-Qt-0.8.9-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/PackageKit-Qt-0.8.9-2.fc20
Comment 2 Fedora Update System 2014-09-04 11:53:21 EDT
PackageKit-Qt-0.8.9-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/PackageKit-Qt-0.8.9-2.fc19
Comment 3 Adam Williamson 2014-09-04 11:55:03 EDT
Fixed in F21 and Rawhide, updates in for F19 and F20.
Comment 4 lnie 2014-09-04 22:36:28 EDT
Tested PackageKit-Qt-0.8.9-2.fc20,the requires for PackageKit is added
Comment 5 Fedora Update System 2014-09-09 18:07:30 EDT
Package PackageKit-Qt-0.8.9-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-Qt-0.8.9-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-10343/PackageKit-Qt-0.8.9-2.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-09-12 13:59:20 EDT
PackageKit-Qt-0.9.2-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/PackageKit-Qt-0.9.2-6.fc21
Comment 7 Fedora Blocker Bugs Application 2014-09-12 14:03:44 EDT
Proposed as a Freeze Exception for 21-alpha by Fedora user rdieter using the blocker tracking app because:

 installing updates via apper on kde spin is currently non-functional (or we can just punt and make it a f21-beta blocker, but since we have the easyfix now...)
Comment 8 Fedora Update System 2014-09-13 02:52:31 EDT
PackageKit-Qt-0.8.9-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Jaroslav Reznik 2014-09-18 07:33:40 EDT
Reopening as we have to be sure this hits Beta. Adding CommonBugs for Alpha.
Comment 10 Fedora Blocker Bugs Application 2014-09-18 07:34:02 EDT
Proposed as a Blocker for 21-beta by Fedora user jreznik using the blocker tracking app because:

 Breaks Beta criterion: "The installed system must be able to download and install updates with the default graphical package manager in all release-blocking desktops." and "Release-blocking desktops must notify the user of available updates, but must not do so when running as a live image." as it fails without PackageKit being not available.
Comment 11 Kevin Kofler 2014-09-18 08:24:44 EDT
Wait, we DIDN'T pull this into Alpha? WTF? WTF do we even have a freeze exception process for? Rex requested the freeze exception 6 days ago, the update was already queued for stable at that time, why TF did it not get pulled into the RC?

Also, working around this in the spin kickstart would have been a 1-line change, if people had just told us that they were not going to pull the fixed package in.

IMHO, Alpha RC1 needs to be a no-go, and we need to pull in this fix and the updated KDE kickstart (size fix, hoping the restoral of PackageKit won't readd too much size) for a new RC. I understand that neither is technically a blocker for Alpha, but at least this issue was filed as a freeze exception well in time, it's not our fault that it has not been processed! (And by the way, I don't understand why working updates are not required for Alpha to begin with.)
Comment 12 Jaroslav Reznik 2014-09-18 09:42:56 EDT
For Alpha, working updates are required but with yum: "The installed system must be able to download and install updates with the default console package manager."

I'd say if we would have to respin, it could be included but we will try to minimize changes between composes and as this is not Alpha blocker, no promises at all.
Comment 13 Adam Williamson 2014-09-19 16:39:50 EDT
"Rex requested the freeze exception 6 days ago, the update was already queued for stable at that time, why TF did it not get pulled into the RC?"

Because the bug got closed by the F20 update push - see c#8. I marked the F20 update as fixing this bug, so the bug got closed when that went stable, and obviously F20 update pushes aren't blocked by the F21 freeze.

Since the bug was closed, it dropped off the FE list and wasn't reviewed at the meetings.

I'm sorry for the mess, it's my fault :( I think when I first sent the F21 build I thought Bodhi hadn't yet been activated so I didn't need to create an update, and also I didn't realize this bug was so important - I thought it just meant you could inadvertently remove PackageKit manually, I didn't realize it was keeping it off the lives. My apologies.
Comment 14 Fedora Update System 2014-09-23 00:34:28 EDT
PackageKit-Qt-0.9.2-6.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2014-10-17 04:38:30 EDT
PackageKit-Qt-0.8.9-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.