Bug 1003203 - Duplicate Provides
Duplicate Provides
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind10 (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 14:45 EDT by Michael Schwendt
Modified: 2013-09-10 21:59 EDT (History)
3 users (show)

See Also:
Fixed In Version: bind10-1.1.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 21:59:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-31 14:45:13 EDT
bind10  from  bind10
    provides libb10-util.so.0()(64bit)
bind10-libs  from  bind10
    provides libb10-util.so.0()(64bit)
    required by: bind10-devel-1.1.0-6.fc20.x86_64
    required by: bind10-dhcp-1.1.0-6.fc20.x86_64
    required by: bind10-dns-1.1.0-6.fc20.x86_64
Comment 1 Fedora Update System 2013-09-02 06:53:01 EDT
bind10-1.1.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-15440/bind10-1.1.0-3.fc19
Comment 2 Michael Schwendt 2013-09-02 07:33:02 EDT
> - Main package now Requires bind10-libs

It already does via the automatic library name deps. The explicit dep on "bind10-libs" is a reverse base package dep and should add %_isa:
https://fedoraproject.org/wiki/Packaging:Guidelines#Requiring_Base_Package
Comment 3 Tomáš Hozza 2013-09-02 08:13:03 EDT
(In reply to Michael Schwendt from comment #2)
> > - Main package now Requires bind10-libs
> 
> It already does via the automatic library name deps.

I know... But because not explicitly requiring the version-release
of the bind10-libs package the bind10-libs package doesn't get updated
in case you update the base package. It caused transaction error.

> The explicit dep on "bind10-libs" is a reverse base package dep and should
> add %_isa:
> https://fedoraproject.org/wiki/Packaging:Guidelines#Requiring_Base_Package

ok, will add it.
Comment 4 Fedora Update System 2013-09-02 19:34:28 EDT
Package bind10-1.1.0-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bind10-1.1.0-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15440/bind10-1.1.0-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-10 21:59:42 EDT
bind10-1.1.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.