Bug 1003206 - [abrt] fldigi-3.21.68-1.fc18: exit: Process /usr/bin/fldigi was killed by signal 11 (SIGSEGV)
[abrt] fldigi-3.21.68-1.fc18: exit: Process /usr/bin/fldigi was killed by sig...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fldigi (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Randall "Randy" Berry
Fedora Extras Quality Assurance
abrt_hash:dcca2a0991d4c15396785be0293...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 16:15 EDT by kb8ecg
Modified: 2013-11-12 20:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 19:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.62 KB, text/plain)
2013-08-31 16:15 EDT, kb8ecg
no flags Details
File: cgroup (127 bytes, text/plain)
2013-08-31 16:15 EDT, kb8ecg
no flags Details
File: core_backtrace (868 bytes, text/plain)
2013-08-31 16:15 EDT, kb8ecg
no flags Details
File: dso_list (8.30 KB, text/plain)
2013-08-31 16:15 EDT, kb8ecg
no flags Details
File: environ (3.24 KB, text/plain)
2013-08-31 16:15 EDT, kb8ecg
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-31 16:16 EDT, kb8ecg
no flags Details
File: maps (29.89 KB, text/plain)
2013-08-31 16:16 EDT, kb8ecg
no flags Details
File: open_fds (1.12 KB, text/plain)
2013-08-31 16:16 EDT, kb8ecg
no flags Details
File: proc_pid_status (790 bytes, text/plain)
2013-08-31 16:16 EDT, kb8ecg
no flags Details

  None (edit)
Description kb8ecg 2013-08-31 16:15:36 EDT
Version-Release number of selected component:
fldigi-3.21.68-1.fc18

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/fldigi
crash_function: exit
executable:     /usr/bin/fldigi
kernel:         3.7.9-201.fc18.i686
runlevel:       N 5
uid:            1000
var_log_messages: Aug 31 16:09:43 excelcior abrt[2773]: Saved core dump of pid 2642 (/usr/bin/fldigi) to /var/tmp/abrt/ccpp-2013-08-31-16:09:42-2642 (96960512 bytes)
xsession_errors: 

Truncated backtrace:
Thread no. 1 (7 frames)
 #1 exit at exit.c:99
 #2 diediedie at misc/stacktrace.cxx:119
 #3 handle_signal at misc/stacktrace.cxx:176
 #5 view_rtty::rx_process at cw_rtty/view_rtty.cxx:514
 #6 rtty::rx_process at cw_rtty/rtty.cxx:584
 #7 trx_trx_receive_loop at trx/trx.cxx:257
 #8 trx_loop at trx/trx.cxx:472
Comment 1 kb8ecg 2013-08-31 16:15:41 EDT
Created attachment 792473 [details]
File: backtrace
Comment 2 kb8ecg 2013-08-31 16:15:45 EDT
Created attachment 792474 [details]
File: cgroup
Comment 3 kb8ecg 2013-08-31 16:15:48 EDT
Created attachment 792475 [details]
File: core_backtrace
Comment 4 kb8ecg 2013-08-31 16:15:52 EDT
Created attachment 792476 [details]
File: dso_list
Comment 5 kb8ecg 2013-08-31 16:15:56 EDT
Created attachment 792477 [details]
File: environ
Comment 6 kb8ecg 2013-08-31 16:16:00 EDT
Created attachment 792478 [details]
File: limits
Comment 7 kb8ecg 2013-08-31 16:16:04 EDT
Created attachment 792479 [details]
File: maps
Comment 8 kb8ecg 2013-08-31 16:16:08 EDT
Created attachment 792480 [details]
File: open_fds
Comment 9 kb8ecg 2013-08-31 16:16:12 EDT
Created attachment 792481 [details]
File: proc_pid_status
Comment 10 Richard Shaw 2013-10-25 14:21:11 EDT
Has there been any additional occurrences of this crash? It's several versions old at this point.
Comment 11 kb8ecg 2013-10-25 20:19:00 EDT
I haven't used it since. I hope to give it a workout this weekend.
One odd thing I noticed. This report shows I'm using version 3.21.68
but i was using 3.21.74.
I have them both installed. Maybe there was some sort of confusconflict
because of that???
Comment 12 kb8ecg 2013-11-09 09:54:56 EST
OK. I finally had a chance to try it again. After a cold boot it worked. Then I closed that version and started up version 3.21.68 and that worked.
When I went back to the newer version 3.21.74 I thne get the following dump:

[dave@excelcior ~]$ fldigi
I: main: appname: fldigi
I: main: NBEMS.DIR not present
I: main: HomeDir: /home/dave/.fldigi/
I: main: RigsDir: /home/dave/.fldigi/rigs/
I: main: ScriptsDir: /home/dave/.fldigi/scripts/
I: main: PalettesDir: /home/dave/.fldigi/palettes/
I: main: LogsDir: /home/dave/.fldigi/logs/
I: main: PicsDir: /home/dave/.fldigi/images/
I: main: HelpDir: /home/dave/.fldigi/help/
I: main: MacrosDir: /home/dave/.fldigi/macros/
I: main: WrapDir: /home/dave/.fldigi/wrap/
I: main: TalkDir: /home/dave/.fldigi/talk/
I: main: TempDir: /home/dave/.fldigi/temp/
I: main: KmlDir: /home/dave/.fldigi/kml/
I: main: PskMailDir: /home/dave/
I: main: DATA_dir: /home/dave/.fldigi/data/
I: main: NBEMS_dir: /home/dave/.nbems/
I: main: ARQ_dir: /home/dave/.nbems/ARQ/
I: main: ARQ_files_dir: /home/dave/.nbems/ARQ/files/
I: main: ARQ_recv_dir: /home/dave/.nbems/ARQ/recv/
I: main: ARQ_send: /home/dave/.nbems/ARQ/send/
I: main: WRAP_dir: /home/dave/.nbems/WRAP/
I: main: WRAP_recv_dir: /home/dave/.nbems/WRAP/recv/
I: main: WRAP_send_dir: /home/dave/.nbems/WRAP/send/
I: main: WRAP_auto_dir: /home/dave/.nbems/WRAP/auto/
I: main: ICS_dir: /home/dave/.nbems/ICS/
I: main: ICS_msg_dir: /home/dave/.nbems/ICS/messages/
I: main: ICS_tmp_dir: /home/dave/.nbems/ICS/templates/
I: main: FLMSG_dir: /home/dave/.nbems/
I: main: FLMSG_dir_default: /home/dave/.nbems/
I: main: FLMSG_WRAP_dir: /home/dave/.nbems/WRAP/
I: main: FLMSG_WRAP_recv_dir: /home/dave/.nbems/WRAP/recv/
I: main: FLMSG_WRAP_send_dir: /home/dave/.nbems/WRAP/send/
I: main: FLMSG_WRAP_auto_dir: /home/dave/.nbems/WRAP/auto/
I: main: FLMSG_ICS_dir: /home/dave/.nbems/ICS/
I: main: FLMSG_ICS_msg_dir: /home/dave/.nbems/ICS/messages/
I: main: FLMSG_ICS_tmp_dir: /home/dave/.nbems/ICS/templates/
I: LoadAndRegister: Opening:/home/dave/.fldigi/data/NAVTEX_Stations.csv
I: LoadAndRegister: Read:/home/dave/.fldigi/data/NAVTEX_Stations.csv with 214 records in 0 seconds
I: LoadAndRegister: Opening:/home/dave/.fldigi/data/nsd_bbsss.txt
I: LoadAndRegister: Read:/home/dave/.fldigi/data/nsd_bbsss.txt with 11558 records in 1 seconds
I: LoadAndRegister: Opening:/home/dave/.fldigi/data/station_table.txt
I: LoadAndRegister: Read:/home/dave/.fldigi/data/station_table.txt with 1515 records in 0 seconds
I: LoadAndRegister: Opening:/home/dave/.fldigi/data/ToR-Stats-SHIP.csv
I: LoadAndRegister: Read:/home/dave/.fldigi/data/ToR-Stats-SHIP.csv with 1752 records in 0 seconds
I: LoadAndRegister: Opening:/home/dave/.fldigi/data/wmo_list.txt
I: LoadAndRegister: Read:/home/dave/.fldigi/data/wmo_list.txt with 15541 records in 0 seconds
I: testCommPorts: Found serial port /dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller_D-if00-port0
I: testCommPorts: Found serial port /dev/ttyS0
I: testCommPorts: Found serial port /dev/ttyS1
I: testCommPorts: Found serial port /dev/ttyS2
I: testCommPorts: Found serial port /dev/ttyS3
I: testCommPorts: Found serial port /dev/ttyUSB0
I: loadDefault: macro file name: /home/dave/.fldigi/macros/macros.mdf
I: loadDefault: loading: /home/dave/.fldigi/macros/macros.mdf
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
I: InitParams: dir=/home/dave/.fldigi/kml/ merge_distance=10000.000000 retention_delay=0 refresh_interval=120 balloon_style=2
I: CreateMainKmlFile: Creating baseFil=/home/dave/.fldigi/kml/fldigi.kml
I: CopyStyleFileIfNotExists: Style file /home/dave/.fldigi/kml/styles.kml not altered
I: ReloadSingleKmlFile: kmlFilNam=/home/dave/.fldigi/kml/User.kml m_merge_dist=10000.000000
I: ReloadSingleKmlFile: kmlFilNam=/home/dave/.fldigi/kml/User.kml loaded sz=2
I: ReloadSingleKmlFile: kmlFilNam=/home/dave/.fldigi/kml/Synop.kml m_merge_dist=10000.000000
I: ReloadSingleKmlFile: kmlFilNam=/home/dave/.fldigi/kml/Synop.kml loaded sz=0
I: ReloadSingleKmlFile: kmlFilNam=/home/dave/.fldigi/kml/Navtex.kml m_merge_dist=10000.000000
I: ReloadSingleKmlFile: kmlFilNam=/home/dave/.fldigi/kml/Navtex.kml loaded sz=0
I: Broadcast: 'Britton' sz=2 time=Permanent nb_broad=1 m_merge_dist=10000.000000
I: init_modem_sync: Call init_modem 63, 0
I: init_modem: mode: 63, freq: 0

Caught signal 11
Aborting fldigi due to a fatal error.
Please report this to:   fldigi-devel@lists.berlios.de
or file a bug report at: https://fedorahosted.org/fldigi/newticket

****** Stack trace:
fldigi[0x8188c4b]
fldigi[0x8188e2c]
[0xb7781400]
fldigi[0x8218613]
fldigi[0x822594b]
fldigi[0x81bd0f0]
/lib/libpthread.so.0[0x4b1aaaff]
/lib/libc.so.6(clone+0x5e)[0x4b0da0ee]

****** Version information:
fldigi 3.21.76
Copyright (C) 2007-2010 Dave Freese, Stelios Bounanos, Leigh Klotz, Remi Chateauneu, and others.
License GPLv3+: GNU GPL version 3 or later <http://www.gnu.org/licenses/gpl-3.0.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

****** Build information:
Build information:
  built          : Sat Sep 28 09:34:08 EDT 2013 by dave@excelcior.westell.com on i686-pc-linux-gnu for i686-pc-linux-gnu

  configure flags: 

  compiler       : gcc version 4.7.2 20121109 (Red Hat 4.7.2-8) (GCC) 

  compiler flags : -I$(srcdir) -I$(srcdir)/include -I$(srcdir)/irrxml -I$(srcdir)/libtiniconv -I$(srcdir)/fileselector -I$(srcdir)/xmlrpcpp -pthread -I/usr/include/alsa -I/usr/include/freetype2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_THREAD_SAFE -D_REENTRANT -I/usr/include/libpng15 -pipe -Wall -fexceptions -O2 -ffast-math -finline-functions -DNDEBUG

  linker flags   : -lportaudio -lm -lpthread -lasound -Wl,-z,relro -lfltk_images -lfltk -lX11 -lsamplerate -lpng15 -ldl -lrt -lpthread

  libraries      : FLTK 1.3.0
                   libsamplerate 0.1.8
                   PortAudio 19

Runtime information:
  system         : Linux excelcior.westell.com 3.7.9-201.fc18.i686 #1 SMP Mon Feb 18 21:31:58 UTC 2013 i686

  libraries      : libsamplerate-0.1.8 (c) 2002-2008 Erik de Castro Lopo
                   PortAudio V19-devel (built May  4 2013 14:00:44) 1899
samplerate for Oscillator:8000
samplerate for Oscillator:8000
I: Preset: Shaper::reset( 45.000000, 8000.000000 )
I: Preset: Shaper::m_table_size = 976
I: Preset: Shaper::reset( 45.000000, 8000.000000 )
I: Preset: Shaper::m_table_size = 976
I: Preset: Shaper::reset( 45.450000, 8000.000000 )
I: Preset: Shaper::m_table_size = 966
I: Preset: Shaper::reset( 45.450000, 8000.000000 )
I: Preset: Shaper::m_table_size = 966
[dave@excelcior ~]$
Comment 13 kb8ecg 2013-11-12 19:37:32 EST
Please close this bug report.
I finally figured out how to uninstall both of the versions I had.
I think installed 3.21.77.
It is working at the moment. I'll create a new report if this version fails.
It could have been a conflict with having 3.21.68 and 3.21.76?!?!
Comment 14 Richard Shaw 2013-11-12 20:17:01 EST
It's possible. I had a similar issue with an alpha version I was testing. There was a certain combination of settings that would cause a crash. In my case it was having the mode set to RTTY and a race condition on multi-threaded machines with initialization of the waterfall.

Note You need to log in before you can comment on or make changes to this bug.