Bug 1003209 - Crashes Android SDK Eclipse after a few minutes
Crashes Android SDK Eclipse after a few minutes
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
: 1006273 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2013-08-31 16:25 EDT by Michael Cronenworth
Modified: 2013-09-10 08:24 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-04 13:06:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
abrt-backtrace-gzipped (15.62 KB, application/gzip)
2013-08-31 16:25 EDT, Michael Cronenworth
no flags Details
hs_error generated when eclipse crashes (21.54 KB, application/gzip)
2013-08-31 16:26 EDT, Michael Cronenworth
no flags Details

  None (edit)
Description Michael Cronenworth 2013-08-31 16:25:01 EDT
Created attachment 792482 [details]

Description of problem: I am using the Eclipse package provided by Google in adt-bundle-linux-x86_64-20130729. After opening a project I can view a source code file but after about 1 to 2 minutes Eclipse crashes. I can even let the program sit idle and it will crash.

Under Fedora 18 the Android SDK worked fine.

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:
1. Start eclipse from Google's package.
2. Open a project and have a source code file open.
3. Click around the source code file. Highlight text. Let it sit idle.

Actual results: Eclipse crashes

Expected results: Eclipse doesn't crash

Additional info: Abrt generated a backtrace but then decided it was "unusable" but I will attach it here anyway.
Comment 1 Michael Cronenworth 2013-08-31 16:26:50 EDT
Created attachment 792483 [details]
hs_error generated when eclipse crashes

This is the hs_error.log file that is generated when Eclipse crashes.
Comment 2 Michael Cronenworth 2013-09-04 12:57:23 EDT
Hello, is there anyone I can ping or a mailing list I can post to to get this issue looked at? I have even tried an older Android SDK (4.2), but the behaviour is the same. I have also tried multiple Fedora 19 computers, but the crash still occurs.
Comment 3 Omair Majid 2013-09-04 13:06:36 EDT
This error in soup_session_detach is a bug in swt. It's fixed in swt upstream and newer eclipse versions (Kepler and later) should contain this fix.

I suppose the Android SDK is built on an older version of swt which does not contain the fix. Sadly, Fedora does not ship the Android SDK, so we can't patch this bug.

That said, you may be able to follow the workaround here:
Comment 4 Michael Cronenworth 2013-09-05 00:11:36 EDT
That doesn't seem to be an option. When I try replacing the SWT plugin with the one from Fedora 19 in eclipse-swt, Eclipse won't start.

The Android SDK provides:
Eclipse 4.2.1

I guess Android development on Fedora 19+ is out of the question.
Comment 5 Severin Gehwolf 2013-09-05 04:34:00 EDT
Re-assigning to eclipse (owner of SWT). Perhaps they'll have some suggestions as to how to work around this problem.
Comment 6 Alexander Kurtakov 2013-09-05 04:50:05 EDT
Michael, there is hardly anything we can do regarding the issue with ADT. You can try running android sdk with -clean option or install swt via p2.
Comment 7 Severin Gehwolf 2013-09-10 08:24:07 EDT
*** Bug 1006273 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.