Bug 1003230 - TC2 netinstaller fails with "script error with package firefox"
TC2 netinstaller fails with "script error with package firefox"
Status: CLOSED DUPLICATE of bug 1003691
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-09-01 01:02 EDT by Dan Mashal
Modified: 2013-09-03 10:40 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 10:40:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packaging.log: packaging: error: %pretrans(firefox-23.0.1-3.fc20.x86_64) scriptlet failed, exit status 127 (1.21 MB, text/plain)
2013-09-01 15:13 EDT, Steve Tyler
no flags Details

  None (edit)
Description Dan Mashal 2013-09-01 01:02:34 EDT
Description of problem:

TC2 netinstaller fails to install

1) Start TC2 netinstaller

2) Choose Cinnamon desktop

"The following error occured while installing. This is a fatal error and installation will be aborted."

"script error with package firefox."
Comment 1 Dan Mashal 2013-09-01 01:07:31 EDT
Reassigning to Anaconda.
Comment 2 Steve Tyler 2013-09-01 15:13:36 EDT
Created attachment 792647 [details]
packaging.log: packaging: error: %pretrans(firefox-23.0.1-3.fc20.x86_64) scriptlet failed, exit status 127

...
19:06:34,971 INFO packaging:  running transaction
19:06:57,792 ERR packaging:  script error with package firefox
19:06:57,792 DEBUG packaging: Traceback (most recent call last):
19:06:57,792 DEBUG packaging: File "/usr/libexec/anaconda/anaconda-yum", line 180, in callback
19:06:57,792 DEBUG packaging: File "/usr/libexec/anaconda/anaconda-yum", line 330, in script_error
19:06:57,793 DEBUG packaging: Exception: script error
19:06:57,793 DEBUG packaging: FATAL ERROR: python callback <bound method RPMCallback.callback of <__main__.RPMCallback object at 0x7ff4107fa910>> failed, aborting!
19:06:57,894 INFO packaging: ==== start rpm scriptlet logs ====
19:06:57,895 INFO packaging: warning: filesystem-3.2-19.fc20.x86_64: Header V3 RSA/SHA256 Signature, key ID 246110c1: NOKEY

19:06:57,895 INFO packaging: error: %pretrans(firefox-23.0.1-3.fc20.x86_64) scriptlet failed, exit status 127

19:06:57,895 INFO packaging: ==== end rpm scriptlet logs ====
Comment 3 Steve Tyler 2013-09-01 15:23:08 EDT
(In reply to Steve Tyler from comment #2)
> Created attachment 792647 [details]
> packaging.log: packaging: error: %pretrans(firefox-23.0.1-3.fc20.x86_64)
> scriptlet failed, exit status 127
...

Reproduced while attempting to install mate, kde, xfce, and lxde all together.[1]
NB: This can be done by first selecting Basic Desktop for the Base Environment under Software Selection.

Tested with:
$ qemu-kvm -m 4096 -hda f20-test-3.img -cdrom ~/xfr/fedora/F20/Alpha/Fedora-20-Alpha-TC2-x86_64-netinst.iso -vga std -boot menu=on

Dan: This looks like a firefox problem, not an anaconda problem.

[1] Attempting to reproduce Bug 1002811.
Comment 4 Jan Sedlák 2013-09-02 05:22:05 EDT
Happened to me when I tried to install Gnome Desktop from netinst.
Comment 5 Tim Flink 2013-09-03 10:40:07 EDT
The firefox packagers are already looking at this issue in #1003691, closing as duplicate

*** This bug has been marked as a duplicate of bug 1003691 ***

Note You need to log in before you can comment on or make changes to this bug.