Bug 1003254 - Unable to add accounts when running gwibber on Xfce
Unable to add accounts when running gwibber on Xfce
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 06:17 EDT by Heiko Adams
Modified: 2014-01-01 00:50 EST (History)
2 users (show)

See Also:
Fixed In Version: gwibber-3.4.2-8.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 21:28:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2013-09-01 06:17:25 EDT
Description of problem:
When running Gwibber on Xfce it's impossible to add accounts to gwibber which makes gwibber nearly unuseable. When running gwibber from a terminal the following backtrace is listed:

(gwibber:14145): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion `!g_slist_find (group, radio_button)' failed

(gwibber:14145): Gtk-CRITICAL **: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed
Traceback (most recent call last):
  File "/bin/gwibber-accounts", line 31, in <module>
    from gi.repository import Gtk, Wnck
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 68, in load_module
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 289, in _load
    self._introspection_module = get_introspection_module(self._namespace)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 268, in get_introspection_module
    module = IntrospectionModule(namespace, version)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 117, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded
Traceback (most recent call last):
  File "/bin/gwibber-accounts", line 31, in <module>
    from gi.repository import Gtk, Wnck
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 68, in load_module
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 289, in _load
    self._introspection_module = get_introspection_module(self._namespace)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 268, in get_introspection_module
    module = IntrospectionModule(namespace, version)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 117, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

Version-Release number of selected component (if applicable):
gwibber-3.4.2-7.fc19.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Log into Xfce
2. Start gwibber
3. Try to add an account to gwibber

Actual results:
Nothing happens if you don't run gwibber from a terminal. Otherwise you'll see the backtrace

Expected results:
Gwibber should work as expected

Additional info:
Comment 1 Tom "spot" Callaway 2013-09-03 14:47:29 EDT
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

That's the issue, you can't cross the Gtk streams in one application.

gwibber is supposed to be gtk3 only. I'm guessing that your xfce install has "libwnck" installed, but not "libwnck3", and because they both provide a file in %{_libdir}/girepository-1.0/ that answers when gi asks for an unversioned "Wnck", you can get this.

I never noticed it before, because, well, I have the whole GNOME 3 stack present. :) Easy enough to fix, I'll just add a Requires: libwnck3.
Comment 2 Fedora Update System 2013-09-03 14:48:23 EDT
gwibber-3.4.2-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gwibber-3.4.2-8.fc18
Comment 3 Fedora Update System 2013-09-03 14:48:32 EDT
gwibber-3.4.2-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gwibber-3.4.2-8.fc19
Comment 4 Fedora Update System 2013-09-04 21:28:15 EDT
gwibber-3.4.2-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-09-13 22:28:09 EDT
gwibber-3.4.2-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jesse Pendergrass 2014-01-01 00:50:37 EST
Hello, 

This problem still persists for me, despite this fix. 

Description of problem:
Running Gwibber in XFCE on Fedora 19, I am unable to add accounts.

This Traceback is listed:
Traceback (most recent call last):
  File "/bin/gwibber-accounts", line 99, in <module>
    from gwibber import accounts
  File "/usr/lib/python2.7/site-packages/gwibber/accounts.py", line 36, in <module>
    globals()[p] = __import__("%s.gtk.%s" % (p,p), fromlist='*')
  File "/usr/share/gwibber/plugins/foursquare/gtk/foursquare/__init__.py", line 1, in <module>
    from gi.repository import GLib, Gtk, Pango, WebKit
  File "/usr/lib64/python2.7/site-packages/gi/importer.py", line 68, in load_module
    dynamic_module._load()
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 289, in _load
    self._introspection_module = get_introspection_module(self._namespace)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 268, in get_introspection_module
    module = IntrospectionModule(namespace, version)
  File "/usr/lib64/python2.7/site-packages/gi/module.py", line 117, in __init__
    repository.require(namespace, version)
gi.RepositoryError: Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded

Version-Release number of selected component (if applicable):
gwibber.x86_64 1:3.4.2-9.fc19

Steps to Reproduce:
1. Log into Xfce
2. Start gwibber from terminal
3. Try to add an account to gwibber

Actual results:
Gwibber does nothing while the backtrace is produced

Expected results:
Gwibber should allow me to start adding twitter and/or facebook accounts.

Additional Information: 
I have reviewed this bug report and this appears to be a known issue that has been resolved, yet I am still getting this error. I am not sure if I'm just missing dependencies or if there is something else wrong with my system. Please advise.

Note You need to log in before you can comment on or make changes to this bug.