Bug 1003266 - [engine-webadmin] uninformative error on UI when remove ISO domain with format fails due to VDSNetworkException
[engine-webadmin] uninformative error on UI when remove ISO domain with forma...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity medium
: ---
: 3.5.0
Assigned To: Tal Nisan
Elad
storage
:
Depends On:
Blocks: rhev3.5beta3
  Show dependency treegraph
 
Reported: 2013-09-01 07:53 EDT by Elad
Modified: 2016-02-10 13:06 EST (History)
11 users (show)

See Also:
Fixed In Version: org.ovirt.engine-root-3.5.0-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: Triaged+


Attachments (Terms of Use)
logs and screenshot (858.60 KB, application/x-gzip)
2013-09-01 07:53 EDT, Elad
no flags Details
engine.log (319.00 KB, application/x-gzip)
2014-10-14 04:18 EDT, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 33442 master MERGED core: Log error correctly when connecting domain for removal Never
oVirt gerrit 33809 ovirt-engine-3.5 MERGED core: Log error correctly when connecting domain for removal Never

  None (edit)
Description Elad 2013-09-01 07:53:34 EDT
Created attachment 792589 [details]
logs and screenshot

Description of problem:
When RemoveStorageDomainCommand with format=true (on ISO domain) fails due to VDSNetworkException, engine reports on UI this error:
"Error while executing action Remove Storage Domain: Internal Engine Error"

This massage is not informative enough, engine should report about the real problem, which is the connectivity issue with vdsm.

on engine.log we get this:

2013-09-01 14:35:57,418 ERROR [org.ovirt.engine.core.bll.storage.ConnectStorageToVdsCommand] (ajp-/127.0.0.1:8702-6) Command org.ovirt.engine.core.bll.storage.ConnectStorageToVdsCommand throw Vdc Bll exception. Wi
th error message VdcBLLException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSNetworkException: java.net.SocketException: Connection reset (Failed with error VDS_NETWORK_ERROR and code 5022)


Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.16.master.el6ev.noarch
rhevm-webadmin-portal-3.3.0-0.16.master.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. have an ISO domain and detach it from DC
2. remove the domain with format, and restart vdsm during the action

Actual results:
Engine fails to send the RemoveStorageDomainCommand to vdsm and We get the mentioned error on UI

Expected results:
engine should report about the real problem, which is the connectivity issue with vdsm.

Additional info: logs and screenshot
Comment 1 Maor 2013-09-02 07:18:50 EDT
Engine should only print an audit log which indicates there was a failure removing the storage domain
Comment 2 Maor 2013-09-02 08:27:30 EDT
The error should seep through the storage helpers to the remove Storage Domain Command.
Right now the storage helpers only return boolean value and therefore the indication of the error get lost from that point beyond.
Comment 4 Eyal Edri 2014-10-07 03:12:45 EDT
this bug status was moved to MODIFIED before engine vt5 was built,
hence moving to on_qa, if this was mistake and the fix isn't in,
please contact rhev-integ@redhat.com
Comment 5 Elad 2014-10-14 04:18:40 EDT
Created attachment 946725 [details]
engine.log

Still getting "Error while executing action Remove Storage Domain: Internal Engine Error" when I try to remove an ISO domain with format while VDSM cannot access the storage.

Used rhev3.5 vt5

Re-openning 

Attaching the logs
Comment 6 Tal Nisan 2014-10-15 04:31:52 EDT
Did you try to reproduce with the exact steps to reproduce? Because it might be a different error than VDS_NETWORK_ERROR
Comment 7 Tal Nisan 2014-10-15 04:45:05 EDT
After discussing with eedri, it seems that this fix did not make it into vt5, moving to modified and it will be featured in the next version
Comment 8 Elad 2014-10-21 06:07:36 EDT
(In reply to Tal Nisan from comment #7)
> After discussing with eedri, it seems that this fix did not make it into
> vt5, moving to modified and it will be featured in the next version

Will test it in the next build
Comment 9 Elad 2014-10-22 08:09:53 EDT
The error message thrown is informative and not generic when ISO domain format fails due to connection loss:

"Error while executing action Remove Storage Domain: Problem while trying to mount target"


Verified using rhev3.5 vt6
Comment 10 Allon Mureinik 2015-02-16 14:12:41 EST
RHEV-M 3.5.0 has been released, closing this bug.
Comment 11 Allon Mureinik 2015-02-16 14:12:42 EST
RHEV-M 3.5.0 has been released, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.