Bug 1003277 - SELinux is preventing /usr/bin/python2.7 from 'unlink' accesses on the file hplip_config_usb_printer.log.
SELinux is preventing /usr/bin/python2.7 from 'unlink' accesses on the file h...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:8524ce2b0f35d56360ec108376b...
:
: 1003174 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 10:39 EDT by nino.corsi
Modified: 2013-09-07 20:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-74.1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-07 20:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nino.corsi 2013-09-01 10:39:13 EDT
Description of problem:
SELinux is preventing /usr/bin/python2.7 from 'unlink' accesses on the file hplip_config_usb_printer.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If si crede che python2.7 dovrebbe avere possibilità di accesso unlink sui hplip_config_usb_printer.log file in modo predefinito.
Then si dovrebbe riportare il problema come bug.
E' possibile generare un modulo di politica locale per consentire questo accesso.
Do
consentire questo accesso per il momento eseguendo:
# grep hp-config_usb_p /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cupsd_log_t:s0
Target Objects                hplip_config_usb_printer.log [ file ]
Source                        hp-config_usb_p
Source Path                   /usr/bin/python2.7
Port                          <Sconosciuto>
Host                          (removed)
Source RPM Packages           python-2.7.5-4.fc19.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.i686 #1 SMP Tue Jun
                              11 20:01:50 UTC 2013 i686 i686
Alert Count                   1
First Seen                    2013-09-01 13:25:34 CEST
Last Seen                     2013-09-01 13:25:34 CEST
Local ID                      e3e95b73-cc46-4f96-bf0c-5db1c976a4b7

Raw Audit Messages
type=AVC msg=audit(1378034734.736:1890): avc:  denied  { unlink } for  pid=29563 comm="hp-config_usb_p" name="hplip_config_usb_printer.log" dev="dm-0" ino=134211 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cupsd_log_t:s0 tclass=file


type=SYSCALL msg=audit(1378034734.736:1890): arch=i386 syscall=unlink success=no exit=EACCES a0=95798c8 a1=0 a2=b7776000 a3=914c050 items=0 ppid=1 pid=29563 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=hp-config_usb_p exe=/usr/bin/python2.7 subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)

Hash: hp-config_usb_p,cupsd_t,cupsd_log_t,file,unlink

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.i686
type:           libreport
Comment 2 Miroslav Grepl 2013-09-02 09:51:28 EDT
*** Bug 1003174 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-09-03 15:57:35 EDT
selinux-policy-3.12.1-74.1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-74.1.fc19
Comment 4 Fedora Update System 2013-09-04 21:39:12 EDT
Package selinux-policy-3.12.1-74.1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-74.1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15819/selinux-policy-3.12.1-74.1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-07 20:37:12 EDT
selinux-policy-3.12.1-74.1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.