Bug 1003410 - Server cursor is broken with blobs in the select list, ORDER BY does not work
Server cursor is broken with blobs in the select list, ORDER BY does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 19:25 EDT by Harald Reindl
Modified: 2013-11-10 02:43 EST (History)
1 user (show)

See Also:
Fixed In Version: mariadb-5.5.33a-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:43:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-09-01 19:25:58 EDT
-------- Original-Nachricht --------
Betreff: Fwd: [Dbmail] MariaDB and dbmail
Datum: Sun, 01 Sep 2013 23:37:13 +0200
Von: Reindl Harald <h.reindl@thelounge.net>
An: Mailing-List dbmail <dbmail@dbmail.org>,  Mailing-List mariadb <"maria-discuss"@lists.launchpad.net>

please can someone from the MariaDB developers
MariaDB 5.5.32 is running here on test-machines

this is todays feedback of the dbmail core-developer and beause
more and more distributions including Fedora/OpenSuSE and AFAIK
even RHEL7 switch to MariaDB this is a *serious* problem which is
not what a "drop-in replacement" should do and a show-stopper
rollout Fedora 19 at all in the near future

> Anyway, MariaDB doesn't even pass the basic unit-tests
>
> Looks like this maybe libzdb related. The ordering of the query
> retrieving mime parts is ok on the console, but *not* when looping
> over the result in libzdb.
>
> MariaDB is *no-go* at this moment. Just what I experienced a year
> ago or so. I'm sorry, but I don't think I'll hold 3.1.4 for that
> not a regression at all.

-------- Original-Nachricht --------
Betreff: Re: [Dbmail] MariaDB and dbmail
Datum: Tue, 02 Apr 2013 19:47:15 +0400
Von: Sergej Pupykin <ml@sergej.pp.ru>
An: DBMail mailinglist <dbmail@dbmail.org>

At Thu, 20 Sep 2012 10:46:52 +0800,
zamri <myzamri@gmail.com> wrote:
> MariaDB is fully compatible with MySQL. Migration is done. So far so good. Phewww!...
> 
> Now I need to do some research on tuning mariadb if needed.

I found that after migration following SQL returns wrong sorted data:

SELECT
    l.part_key,
    l.part_depth,
    l.part_order,
    l.is_header,
    DATE_FORMAT(ph.internal_date,GET_FORMAT(DATETIME,'ISO')),
    data
FROM
    dbmail_mimeparts p
JOIN dbmail_partlists l ON p.id = l.part_id
JOIN dbmail_physmessage ph ON ph.id = l.physmessage_id
WHERE l.physmessage_id = <ID>
ORDER BY l.part_key,l.part_order ASC;

however when I run it from command line it works well.

Probably it does not fail always because of not all emails damaged.

Not sure if it caused by migration to mariadb, but problem appeared
near same time
Comment 1 Harald Reindl 2013-09-02 09:17:59 EDT
https://mariadb.atlassian.net/browse/MDEV-4978
Comment 2 Honza Horak 2013-09-02 10:04:33 EDT
Thanks for getting this visible in Fedora, I'll keep an eye on the upstream bug report.
Comment 3 Harald Reindl 2013-09-06 09:32:37 EDT
looks like upstream has cooked a fix while i am unable to locate it currently for testing - maybe the fedora packager is more firm with the MariaDB upstream sources

https://mariadb.atlassian.net/browse/MDEV-4978?focusedCommentId=34462&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-34462
Comment 4 Honza Horak 2013-09-10 08:38:55 EDT
Right, the patch is here:
http://bazaar.launchpad.net/~maria-captains/maria/5.5/revision/3878

However, I believe the new upstream release is going to be released very soon, so I'd rather wait for mariadb-5.5.33, where this issue will be fixed.
Comment 5 Harald Reindl 2013-09-17 15:49:22 EDT
MariaDB 5.5.33 is out!

this bug is now finally confirmed as fixedwith my dbmail-tests
hopefully it was the only one failing dbmail-requirements

something is changed in the location of docdir-files with 5.5.33
useless to provide my SPEC changes because I#m far form Fedora packaging

however, it builds, it works, it's fine AFAIK
mariadb-server-5.5.33-5.fc18.20130917.rh.x86_64
mariadb-server-5.5.33-5.fc19.20130917.rh.x86_64

____________________________________________________

The MariaDB project is pleased to announce the immediate availability
of MariaDB 5.5.33.

This release features the addition of TokuDB as an additional storage
engine option. There are also bug and other fixes. See the Release
Notes and Changelog for details.

MariaDB 5.5.33 Stable (GA)
 - Release Notes: https://mariadb.com/kb/en/mariadb-5533-release-notes
 - Changelog: https://mariadb.com/kb/en/mariadb-5533-changelog
 - Downloads: https://downloads.mariadb.org/mariadb/5.5.33
Comment 6 Harald Reindl 2013-09-18 13:45:10 EDT
BTW if you update Fedora to 5.5.33 be aware it bundles jemalloc
with these two switches you can use the system-library
with only the first one you disable jemalloc at all

 -DWITH_JEMALLOC=no \
 -DLIBJEMALLOC=jemalloc \

after i cried out loud on the mailing-list with 5.5.34 we get
-DWITH_JEMALLOC=system supported, the reason for the outdated
bundeled version has a context to TokuDB, no idea what fedora 
does in that case

our companies builds will use -DWITHOUT_DYNAMIC_PLUGINS=ON
and so TokuDB doe snot matter at all for me
Comment 7 Harald Reindl 2013-09-20 05:10:26 EDT
wait a moment for 5.5.33a :-)

> I've begun the prep for the special 5.5.33a release.
>
> Draft changelog and release notes are here:
>
> https://mariadb.com/kb/en/mariadb-5533a-changelog/
> https://mariadb.com/kb/en/mariadb-5533a-release-notes/

https://mariadb.atlassian.net/browse/MDEV-5026
cmake -DWITH_JEMALLOC=system
Comment 8 Harald Reindl 2013-09-20 14:27:34 EDT
-------- Original-Nachricht --------
Betreff: [Maria-discuss] MariaDB 5.5.33a Now Available
Datum: Fri, 20 Sep 2013 12:52:42 -0400
Von: Daniel Bartholomew <dbart@mariadb.com>
An: maria-discuss <maria-discuss@lists.launchpad.net>

The MariaDB project is pleased to announce the immediate availability
of MariaDB 5.5.33a.

This is a special bug-fix release to address some packaging and other
bugs present in the recent MariaDB 5.5.33 release. See the release notes
and changelog for details.

- - Links  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

MariaDB 5.5.33a Stable (GA)
 - Release Notes: https://mariadb.com/kb/en/mariadb-5533a-release-notes
 - Changelog: https://mariadb.com/kb/en/mariadb-5533a-changelog
 - Downloads: https://downloads.mariadb.org/mariadb/5.5.33a
Comment 9 Fedora Update System 2013-10-14 14:25:35 EDT
mariadb-5.5.33a-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mariadb-5.5.33a-2.fc20
Comment 10 Fedora Update System 2013-10-15 02:36:07 EDT
Package mariadb-5.5.33a-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mariadb-5.5.33a-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19096/mariadb-5.5.33a-2.fc20
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-11-10 02:43:30 EST
mariadb-5.5.33a-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.