Bug 1003469 - win2012 guest and qemu-kvm hang when hotplug virtio scsi disk less than 1000
win2012 guest and qemu-kvm hang when hotplug virtio scsi disk less than 1000
Status: CLOSED DUPLICATE of bug 996809
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Asias He
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 02:50 EDT by zhonglinzhang
Modified: 2013-09-18 00:52 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 00:52:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhonglinzhang 2013-09-02 02:50:17 EDT
Description of problem:
When hotplug access to 1000 virtio scsi disk, win2012 guest and qemu-kvm hang.

Version-Release number of selected component (if applicable):
kernel: 2.6.32-414.el6.x86_64
qemu-kvm: qemu-kvm-0.12.1.2-2.398.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
  1. boot win2012 guest with following command line:
/usr/libexec/qemu-kvm -M pc -enable-kvm -m 200G -smp 32,sockets=4,cores=8,threads=1 -name scalability-test -rtc base=localtime,clock=host,driftfix=slew -k en-us -boot menu=on -spice disable-ticketing,port=5931 -vga qxl -monitor stdio -drive file=/home/win2012-64-virtio.qcow2,if=none,id=drive-system-disk,media=disk,format=qcow2,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-system-disk,id=system-disk,addr=0x9 -device virtio-scsi-pci,id=bus1,bus=pci.0,addr=0x5 -monitor unix:/tmp/monitor11,server,nowait

  2. hotplug virtio-scsi with this script: 
#sh test.sh 
#cat test.sh
i=0
j=0
while [ $i -lt 16666 ]
do
j=$((i%255))

sleep 5
if ((i>5000)) ;then
     sleep 5
fi

echo "__com.redhat_drive_add file=/home/storage/usb-storage$i.qcow2,format=qcow2,media=disk,id=scsi$i" | nc -U /tmp/monitor11
echo "device_add scsi-hd,bus=bus1.0,drive=scsi$i,scsi-id=$j,id=hd$i" |nc -U /tmp/monitor11
i=$(($i+1))
done

  3. (qemu) info block
scsi993: removable=0 io-status=ok file=/home/storage/usb-storage993.qcow2 ro=0 drv=qcow2 encrypted=0
scsi994: removable=0 io-status=ok file=/home/storage/usb-storage994.qcow2 ro=0 drv=qcow2 encrypted=0
scsi995: removable=0 io-status=ok file=/home/storage/usb-storage995.qcow2 ro=0 drv=qcow2 encrypted=0
scsi996: removable=0 io-status=ok file=/home/storage/usb-storage996.qcow2 ro=0 drv=qcow2 encrypted=0
scsi997: removable=0 io-status=ok file=/home/storage/usb-storage997.qcow2 ro=0 drv=qcow2 encrypted=0
scsi998: removable=0 io-status=ok file=/home/storage/usb-storage998.qcow2 ro=0 drv=qcow2 encrypted=0
(qemu)

Actual results:
windows2012 guest and qemu-kvm hang when hotplug virtio scsi disk less than 1000

Expected results:
windows2012 guest and qemu-kvm should be work well

Additional info:
rhel6.5 guest can hotplug more than 13000 virtio scsi disk
Comment 2 Asias He 2013-09-18 00:52:10 EDT

*** This bug has been marked as a duplicate of bug 996809 ***

Note You need to log in before you can comment on or make changes to this bug.