Bug 1003492 - [RFE] single step snapshot to template in RHEV-M (VM not running)
Summary: [RFE] single step snapshot to template in RHEV-M (VM not running)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Arik
QA Contact: sefi litmanovich
URL:
Whiteboard:
Depends On:
Blocks: 1231131
TreeView+ depends on / blocked
 
Reported: 2013-09-02 07:53 UTC by Evgheni Dereveanchin
Modified: 2019-04-28 09:45 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The process to create a template from a virtual machine snapshot has been simplified. Previously the user needed to create a virtual machine from a snapshot, and then create a template from the virtual machine. The new process enables the user to create the template directly from the snapshot.
Clone Of:
: 1231131 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:32:46 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 41257 master MERGED core: extract initialization in add-template to init method Never
oVirt gerrit 41258 master MERGED core: add template from snapshot Never
oVirt gerrit 41259 master MERGED webadmin: add template from snapshot Never
oVirt gerrit 41412 master MERGED core: configurable parent for create image template Never

Description Evgheni Dereveanchin 2013-09-02 07:53:42 UTC
Description of problem:

It is tedious to create an export or a template from a running machine:
VM->snapshot->clone->template(->remove clone)(->remove snapshot)
VM->snapshot->clone->export(->remove clone)(->remove snapshot)
Having a single rhevm-shell command and web-gui operation to perform these would be very useful

Version-Release number of selected component (if applicable):
3.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Multiple steps needed to create an export/template of a running VM

Expected results:
Single step option (context menu in admin web ui + CLI command)

Additional info:

Comment 6 Michal Skrivanek 2015-05-21 15:15:14 UTC
we have an implementation for Down VMs
Operating on running VMs is bit more complex and not part of the changes which will get in 3.6 at this point.
Do you want to keep this RFE still open since the request was explicitly about running VMs or is it good enough?

Comment 7 Evgheni Dereveanchin 2015-05-22 05:47:04 UTC
Yes, we are aware that creating templates and exporting powered off VMs is exists. In fact it is the only way at the moment. This RFE was there to specifically add support of doing these actions on running Vms. 

There is already a way to do this described in #0 however it is too complicated. Please keep this request open.

Comment 8 Michal Skrivanek 2015-05-22 09:38:49 UTC
thank you for confirmation.
So at this point I can confirm we will have an improvement in 3.6 for the down VMs only (single step)
adding exception request to try to address the remaining "bug" that it doesn't work on running VMs

Comment 9 Max Kovgan 2015-06-28 14:13:47 UTC
ovirt-3.6.0-3 release

Comment 10 sefi litmanovich 2015-12-28 12:57:35 UTC
Verified on rhevm-3.6.2-0.1.el6.noarch.

1. Created a vm (from some template).
2. started vm.
3. Created snapshot.
4. created template from snapshot.

works the same with non live snapshot.
works the same when creating template subversion.

Comment 12 errata-xmlrpc 2016-03-09 20:32:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.