Bug 1003503 - Action 'Upload document to merge/override current translation' fails while 'Merge?' option unchecked with Zanata version 3.0.2 (20130816-0408)
Action 'Upload document to merge/override current translation' fails while 'M...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Patrick Huang
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 04:33 EDT by sandeep shedmake
Modified: 2013-09-04 02:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 02:24:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sshedmak: needinfo+


Attachments (Terms of Use)

  None (edit)
Description sandeep shedmake 2013-09-02 04:33:04 EDT
Description of problem:
Action 'Upload document to merge/override current translation' fails while 'Merge?' option is unchecked, 'Upload File' selected and 'Upload' button is pressed.


Version-Release number of selected component (if applicable):
Zanata version 3.0.2 (20130816-0408)


How reproducible:
Always


Steps to Reproduce:
1. Login to Zanata version 3.0.2 (20130816-0408) UI with appropriate user credentials
2. For an available project, initiate action 'Upload document to merge/override current translation'
3. Uncheck 'Merge?' options and select file for 'Upload file' option
4. Click 'Upload' button


Actual results:
Error: You do not have permission to access this resource.


Expected results:
File Uploaded.


Additional info:
Action 'Upload document to merge/override current translation' fails while 'Merge?' option is unchecked, 'Upload File' selected and 'Upload' button is pressed worked successfully with Zanata version 2.2.2 (20130306-2037).
Comment 1 Patrick Huang 2013-09-04 00:25:49 EDT
We added a permission check to only allow project maintainer to override translation (i.e. with merge option unchecked). 
If merge option is checked, it allows translator to upload translation.
If merge option is unchecked, only project maintainer can upload translation.
Are you a project maintainer for the project?
Comment 2 sandeep shedmake 2013-09-04 00:58:54 EDT
(In reply to Patrick Huang from comment #1)
> We added a permission check to only allow project maintainer to override
> translation (i.e. with merge option unchecked).

I assume this permission check is only added with Zanata version 3.0.2 (20130816-0408). 
 
> If merge option is checked, it allows translator to upload translation.

If server copy has fuzzy messages; localizer/translator can't override the fuzzy fixes (using off-line PO based editor) and upload (merge option checked) it to zanata server.


> If merge option is unchecked, only project maintainer can upload translation.
> Are you a project maintainer for the project?

No, I am not the project maintainer for the project.

If the above permission check is only allowed to project maintainer, then I will put a request as an additional maintainer.

I hugely favour override translation option (i.e. with merge option unchecked). 

Also overriding translation option worked well for me with Zanata version 2.2.2 (20130306-2037). It's just failing for Zanata version 3.0.2 (20130816-0408).


Thanks.
-Sandeep
Comment 3 Patrick Huang 2013-09-04 01:14:39 EDT
(In reply to sandeep shedmake from comment #2)
> (In reply to Patrick Huang from comment #1)
> > We added a permission check to only allow project maintainer to override
> > translation (i.e. with merge option unchecked).
> 
> I assume this permission check is only added with Zanata version 3.0.2
> (20130816-0408). 
>  
> > If merge option is checked, it allows translator to upload translation.
> 
> If server copy has fuzzy messages; localizer/translator can't override the
> fuzzy fixes (using off-line PO based editor) and upload (merge option
> checked) it to zanata server.
I assume you mean merge option unchecked? In any case, if the use case is to override fuzzy messages with off-line PO file, you should really use the merge option. If off-line PO file has better translation (meaning it's NOT fuzzy), it will override it. Otherwise it will leave it as is. Override (merge option unchecked) is consider dangerous as it will override regardless even if the server has better/latest/more translation, i.e. someone translate it online while you are working off-line.   

Can you try with merge option checked? See if that address your need.

> 
> > If merge option is unchecked, only project maintainer can upload translation.
> > Are you a project maintainer for the project?
> 
> No, I am not the project maintainer for the project.
> 
> If the above permission check is only allowed to project maintainer, then I
> will put a request as an additional maintainer.
> 
> I hugely favour override translation option (i.e. with merge option
> unchecked). 
> 
> Also overriding translation option worked well for me with Zanata version
> 2.2.2 (20130306-2037). It's just failing for Zanata version 3.0.2
> (20130816-0408).
> 
> 
> Thanks.
> -Sandeep
Comment 4 sandeep shedmake 2013-09-04 02:14:29 EDT
(In reply to Patrick Huang from comment #3)
> (In reply to sandeep shedmake from comment #2)
> > (In reply to Patrick Huang from comment #1)
> > > We added a permission check to only allow project maintainer to override
> > > translation (i.e. with merge option unchecked).
> > 
> > I assume this permission check is only added with Zanata version 3.0.2
> > (20130816-0408). 
> >  
> > > If merge option is checked, it allows translator to upload translation.
> > 
> > If server copy has fuzzy messages; localizer/translator can't override the
> > fuzzy fixes (using off-line PO based editor) and upload (merge option
> > checked) it to zanata server.
> I assume you mean merge option unchecked? 

Yes, I meant merge option unchecked.

> In any case, if the use case is to
> override fuzzy messages with off-line PO file, you should really use the
> merge option. 

Okay.

> If off-line PO file has better translation (meaning it's NOT
> fuzzy), it will override it. Otherwise it will leave it as is. Override
> (merge option unchecked) is consider dangerous as it will override
> regardless even if the server has better/latest/more translation, i.e.
> someone translate it online while you are working off-line.   
> 

Okay.


> Can you try with merge option checked? See if that address your need.

Yes, with 'merge' option checked addresses the need.


Translation override used to work neatly with 'Translator' and 'Co-ordinator' role until Zanata 3.0.2. Hence, the reason for filing this bug.


Thanks.
-Sandeep

> > 
> > > If merge option is unchecked, only project maintainer can upload translation.
> > > Are you a project maintainer for the project?
> > 
> > No, I am not the project maintainer for the project.
> > 
> > If the above permission check is only allowed to project maintainer, then I
> > will put a request as an additional maintainer.
> > 
> > I hugely favour override translation option (i.e. with merge option
> > unchecked). 
> > 
> > Also overriding translation option worked well for me with Zanata version
> > 2.2.2 (20130306-2037). It's just failing for Zanata version 3.0.2
> > (20130816-0408).
> > 
> > 
> > Thanks.
> > -Sandeep
Comment 5 Patrick Huang 2013-09-04 02:24:28 EDT
We found the potential danger of override translation may cause hence restricted it in last release. Sorry about the inconvenience the change may have caused. 

We are undertaking an overall documentation task in current development cycle. The goal is to have a more user friendly user interface complemented with documentation/online help/change log etc. Hopefully in the future it will be easier for users to understand Zanata.

I will close this bug.

Note You need to log in before you can comment on or make changes to this bug.