Bug 1003504 - when installing SAM and services do not get started, katello-configure ends with 0
when installing SAM and services do not get started, katello-configure ends w...
Status: CLOSED WONTFIX
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.0
Assigned To: Katello Bug Bin
SAM QE List
: Regression, Reopened, Triaged
Depends On:
Blocks: sam20-tracker
  Show dependency treegraph
 
Reported: 2013-09-02 04:33 EDT by Jan Hutař
Modified: 2017-06-26 16:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 16:34:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-02 04:33:58 EDT
Description of problem:
I have installed katello-headpin-all and Splaice packages and run katello-configure multiple times. I got to the state when related services do not get started and katello-configure ended with 0 and did not printed any error.

I have checked documentation for SAM 1.2 (can not find one for 1.3) and there is:

[...]
If the configuration script encounters an error, it will display details of the error, for example: 
[...]

so I consider this a regression.


Version-Release number of selected component (if applicable):
katello-configure-1.4.4-3.el6sat.noarch


How reproducible:
consistently in my case


Steps to Reproduce:
1. I got to the state when katello services can not get started somehow
2. # katello-configure --deployment=sam --user-pass=<user> --user-pass=<pass> --user-email=jhutar@redhat.com --reset-data='YES' --org-name=jhutar


Actual results:
# grep -i error /var/log/katello/katello-configure-20130902-041433/main.log
130902-04:16:39 Error: Could not start Service[katello-jobs]: Execution of '/sbin/service katello-jobs start' returned 1: 
130902-04:16:39 Error: /Stage[main]/Katello::Service/Service[katello-jobs]/ensure: change from stopped to running failed: Could not start Service[katello-jobs]: Execution of '/sbin/service katello-jobs start' returned 1:
# echo $?
0


Expected results:
In case of any error, error should be printer and exit code should be != 0.
Comment 2 Tom McKay 2013-09-02 08:15:05 EDT
Please include katello-debug and splice-debug outputs as attachments.
Comment 7 RHEL Product and Program Management 2013-09-17 00:16:21 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 12 Bryan Kearney 2014-05-08 08:11:28 EDT
katello-configure has been deprecated.
Comment 13 Jan Hutař 2014-05-09 17:16:53 EDT
Please reconsider as this is against SAM (probably incorrectly filled against Sat6, but in the time of filling it i have been told it does not matter where to file it).
Comment 17 Bryan Kearney 2017-06-26 16:34:26 EDT
The release of Satellite 5.8 we are deprecating the support of Subscription Asset Manager. The release notes for 5.8 can be found at https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/pdf/release_notes/Red_Hat_Satellite-5.8-Release_Notes-en-US.pdf.

I am therefore closing out this bug as WONTFIX. If you believe this to be an error, please feel free tor each out to either Rich Jerrido or Bryan Kearney. Thank you!

Note You need to log in before you can comment on or make changes to this bug.