Bug 1003511 - rpc.idmapd command options and man pages should update,,,
Summary: rpc.idmapd command options and man pages should update,,,
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides   
(Show other bugs)
Version: 6.4
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On: 1003510 1003513
Blocks: 1119230
TreeView+ depends on / blocked
 
Reported: 2013-09-02 08:51 UTC by Yin.JianHong
Modified: 2014-10-14 07:26 UTC (History)
4 users (show)

Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: -d, -G and -U options were removed from command but still presented in the man page Consequence: unsupported options were documented Fix: remove options from man page Result: options not documented in the man page
Story Points: ---
Clone Of: 1003510
Environment:
Last Closed: 2014-10-14 07:26:16 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpc.idmapd -dUG removed plus -CS added to synopsis (2.09 KB, patch)
2014-06-20 11:49 UTC, Jan Chaloupka
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC

Description Yin.JianHong 2013-09-02 08:51:13 UTC
+++ This bug was initially created as a clone of Bug #1003510 +++

Description of problem:
rpc.idmapd command options and man pages should update,,,
the -d -U -G have been removed, should update the man page;
and if specify -d or -U or -G, In addition to output error
 -and should do more: output the right usage.

[root@dell-pr7610-01 ~]# rpc.idmapd -d domain 
rpc.idmapd: the -d, -U, and -G options have been removed; please use the configuration file instead.
[root@dell-pr7610-01 ~]# man rpc.idmapd | cat -
RPC.IDMAPD(8)                                                 BSD System Manager's Manual                                                 RPC.IDMAPD(8)

NAME
     rpc.idmapd — NFSv4 ID <-> Name Mapper

SYNOPSIS
     rpc.idmapd [-v] [-f] [-d domain] [-p path] [-U username] [-G groupname] [-c path]

DESCRIPTION
     rpc.idmapd is the NFSv4 ID <-> name mapping daemon.  It provides functionality to the NFSv4 kernel client and server, to which it communicates via
     upcalls, by translating user and group IDs to names, and vice versa.

     The options are as follows:

     -v           Increases the verbosity level (can be specified multiple times).

     -f           Runs rpc.idmapd in the foreground and prints all output to the terminal.

     -d domain    Set domain to domain.  This is used internally by NFSv4 and is typically assigned by the system administrator.  By default, domain is
                  set to be the FQDN of the host, minus the hostname.

     -p path      Specifies the location of the RPC pipefs to be path.  The default value is "/var/lib/nfs/rpc_pipefs".

     -U username  Specifies the NFSv4 nobody user to be username.  The default value is "nobody".

     -G groupname
                  Specifies the NFSv4 nobody group to be groupname.  The default value is "nobody".

     -c path      Use configuration file path.

     -C           Client-only: perform no idmapping for any NFS server, even if one is detected.

     -S           Server-only: perform no idmapping for any NFS client, even if one is detected.

EXAMPLES
     rpc.idmapd -d "citi.umich.edu" -f -vvv



Version-Release number of selected component (if applicable):
all version in  from RHEL5.9 5.10 RHEL6.x to RHEL7.x

How reproducible:
y

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
update usage output, and man pages

Additional info:

Comment 2 RHEL Product and Program Management 2013-10-14 02:26:57 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 3 Jan Chaloupka 2014-06-20 11:49:32 UTC
Created attachment 910764 [details]
rpc.idmapd -dUG removed plus -CS added to synopsis

Patch for man page: synopsis, options, example modified.

Running
# rpc.idmapd -h
rpc.idmapd: '-h' is an invalid argument.
# rpc.idmapd --help
rpc.idmapd: '--' is an invalid argument.

no help -> no usage modified

Comment 12 errata-xmlrpc 2014-10-14 07:26:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.