Bug 1003539 - If rpc.mountd specify options: "-N 2 -N 3 -N 4", should output more readable info to user
Summary: If rpc.mountd specify options: "-N 2 -N 3 -N 4", should output more readable ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.0
Hardware: All
OS: Linux
high
low
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On: 1003536
Blocks: 1003538
TreeView+ depends on / blocked
 
Reported: 2013-09-02 10:04 UTC by JianHong Yin
Modified: 2016-11-04 04:59 UTC (History)
3 users (show)

Fixed In Version: nfs-utils-1.3.0-0.23.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1003536
Environment:
Last Closed: 2016-11-04 04:59:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description JianHong Yin 2013-09-02 10:04:20 UTC
+++ This bug was initially created as a clone of Bug #1003536 +++

Description of problem:
if rpc.mountd specify options: "-N 2 -N 3 -N 4", should output more readable info to user

Version-Release number of selected component (if applicable):
all version from RHEL5.9 RHEL5.10 RHEL6.x RHEL7.0

How reproducible:
y

Steps to Reproduce:
1. 
2.
3.

Actual results:
[root@dell-pr7610-01 ~]# rpc.mountd -N 2 -N 3 -N 4
Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
        [-o num|--descriptors num] [-f exports-file|--exports-file=file]
        [-p|--port port] [-V version|--nfs-version version]
        [-N version|--no-nfs-version version] [-n|--no-tcp]
        [-H ha-callout-prog] [-s|--state-directory-path path]
        [-g|--manage-gids] [-t num|--num-threads=num]

Expected results:
should output info to notify user, why error:
example: your can not disable all version of mountd

Additional info:

--- Additional comment from Yin.JianHong on 2013-09-02 06:01:49 EDT ---

[root@dell-pr7610-01 ~]# rpc.mountd --no-nfs-version 2 --no-nfs-version 3 --no-nfs-version 4
Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
        [-o num|--descriptors num] [-f exports-file|--exports-file=file]
        [-p|--port port] [-V version|--nfs-version version]
        [-N version|--no-nfs-version version] [-n|--no-tcp]
        [-H ha-callout-prog] [-s|--state-directory-path path]
        [-g|--manage-gids] [-t num|--num-threads=num]

Comment 2 RHEL Program Management 2014-03-22 06:39:45 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Steve Dickson 2016-01-20 19:17:49 UTC
commit 6ec0d58fbff7c1a814a21cf8c7fe0ef5106a04c1
Author: Steve Dickson <steved@redhat.com>
Date:   Wed Jan 20 14:16:08 2016 -0500

    mountd: print an error message when no versions are specified
    
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 9 Yongcheng Yang 2016-05-17 06:12:17 UTC
Move to VERIFIED according to comment 8.

Will continue to run the automatic case in the future 7.3 test round.

Comment 11 errata-xmlrpc 2016-11-04 04:59:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.