Bug 1003544 - Multi-byte patch breaks sorting by non-first field
Multi-byte patch breaks sorting by non-first field
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Oprala
Fedora Extras Quality Assurance
: Regression
: 1055597 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 06:21 EDT by Petr Pisar
Modified: 2015-01-15 22:36 EST (History)
8 users (show)

See Also:
Fixed In Version: coreutils-8.21-20.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-09 02:36:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-09-02 06:21:43 EDT
coreutils-8.21-18 breaks sorting by non-first field:

$ cat test 
x  A 1
x  B 1
xx A 2
xx B 2
$ <test sort -k2
x  A 1
x  B 1
xx A 2
xx B 2
$ rpm -qf $(type -p sort)
coreutils-8.21-18.fc20.x86_64

This is a regression against 8.21-16:

$ rpm -qf $(type -p sort)
coreutils-8.21-16.fc20.x86_64
$ <test sort -k2
x  A 1
xx A 2
x  B 1
xx B 2

This happens if field 1 (the x's) differs in length. It does not depend on locale.
Comment 1 Ondrej Vasik 2013-09-02 08:09:57 EDT
Thanks for report, most probably caused by the changes from http://pkgs.fedoraproject.org/cgit/coreutils.git/commit/coreutils-i18n.patch?id=0dcc5a0d5eb1554f4b5c0d2f2c8988b6b91e6553 ... Moving to the Ondrej Oprala, who was the author of the patch change.
Comment 2 Fedora Update System 2014-01-06 06:39:23 EST
coreutils-8.21-20.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/coreutils-8.21-20.fc20
Comment 3 Fedora Update System 2014-01-07 04:38:12 EST
Package coreutils-8.21-20.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing coreutils-8.21-20.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0287/coreutils-8.21-20.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2014-01-09 02:36:32 EST
coreutils-8.21-20.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Pádraig Brady 2015-01-15 22:36:51 EST
*** Bug 1055597 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.