Bug 1003552 - Cluster demo Readme bugs
Cluster demo Readme bugs
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity low
: ER7
: 6.0.0
Assigned To: Julian Coleman
Pavel Drozd
: Reopened
: 1018899 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 07:00 EDT by Pavel Drozd
Modified: 2015-07-30 04:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 04:34:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1685 Major Closed Upgrade jboss-as-maven version to 7.4.Final 2015-07-30 04:34:19 EDT

  None (edit)
Description Pavel Drozd 2013-09-02 07:00:30 EDT
Readme of cluster demo contains following problems:

Section 3, Build the client and service applications: 
change "cd quickstarts/demos/cluster" to "cd quickstarts/switchyard/demos/cluster"

Section 3, Deploy services:
change in all deploy statements "-Ddeploy.port" to "-Djboss-as.port"
Comment 2 Keith Babo 2013-09-03 10:46:31 EDT
Re: the instructions to build, this seems like a packaging/productization issue more than an issue with the quickstart documentation.  The product is using a different location for the quickstarts than the project.

Does "-Ddeploy.port" not work with the version of the AS deploy plugin packaged in the product?  I don't have any issues using this property with EAP 6.1.
Comment 3 Pavel Drozd 2013-09-03 18:00:01 EDT
The "-Ddeploy.port" does not work with ER1. The default port is used:

mvn -Ddeploy.port=10999 jboss-as:deploy

INFO: JBoss Remoting version 3.2.12.GA
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 17.565s
[INFO] Finished at: Tue Sep 03 23:54:21 CEST 2013
[INFO] Final Memory: 40M/483M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.jboss.as.plugins:jboss-as-maven-plugin:7.4.Final:deploy (default-cli) on project switchyard-quickstart-demo-cluster-client: Could not execute goal deploy on /home/pdrozd/workspace/AS/jboss-eap-6.1-ER1/quickstarts/switchyard/demos/cluster/client/target/switchyard-quickstart-demo-cluster-client.jar. Reason: I/O Error could not execute operation '{
[ERROR] "address" => [],
[ERROR] "operation" => "read-attribute",
[ERROR] "name" => "launch-type"
[ERROR] }': java.net.ConnectException: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out
[ERROR] -> [Help 1]
[ERROR]
Comment 4 Keith Babo 2013-09-03 19:02:13 EDT
Ugh.  Version of the maven plugin used in the community project is 7.1.1.

Tom - can you have a look at this one and see if there's any harm in bumping jboss-as-maven-plugin to 7.4?  If it's still good on the community side, let's align with what's being used in productization and update the Readme accordingly.
Comment 5 tcunning 2013-09-05 14:42:31 EDT
I went through and tested the quickstarts that had a Readme mentioning the jboss-as:deploy step, saw no issues.    Submitted pull.
Comment 6 JBoss JIRA Server 2013-09-26 08:35:07 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1685

Tom - fix for this issue requires an update to the README in quickstarts/demo/cluster as well, right?
Comment 7 JBoss JIRA Server 2013-09-26 08:36:38 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1685

I went ahead and added the commit for quickstarts:
https://github.com/jboss-switchyard/quickstarts/commit/ffd4b1475ab6cb7a73d83035dc20edd90fc79499
Comment 8 JBoss JIRA Server 2013-09-26 08:36:46 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1685

pushed
Comment 12 Keith Babo 2013-10-14 14:44:39 EDT
*** Bug 1018899 has been marked as a duplicate of this bug. ***
Comment 13 Pavel Drozd 2013-12-12 09:25:00 EST
The first part of the bug description is not fixed:

Section 3, Build the client and service applications: 
change "cd quickstarts/demos/cluster" to "cd quickstarts/switchyard/demos/cluster"
Comment 14 Keith Babo 2013-12-12 09:57:04 EST
The project doesn't include a switchyard directory within quickstarts, so fixing the README upstream is not appropriate.  I have reassigned to the build component in case prod wants to make an adjustment.
Comment 16 JBoss JIRA Server 2014-06-16 19:49:32 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1685 to Closed

Note You need to log in before you can comment on or make changes to this bug.