Bug 1003587 - firefox-23.0.1-3.fc20.x86_64 build with xulrunner-23.0.1-1.fc20.x86_64 ?
firefox-23.0.1-3.fc20.x86_64 build with xulrunner-23.0.1-1.fc20.x86_64 ?
Status: CLOSED DUPLICATE of bug 1003691
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
20
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kamil Dudka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 08:46 EDT by Dethlef Madsen
Modified: 2013-09-04 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 12:29:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dethlef Madsen 2013-09-02 08:46:45 EDT
Description of problem:

I tried to build a fedora-live-cd which ends with error: 

Error creating Live CD : Dependency check failed : (('firefox', '23.0.1', '3.fc20'), ('/bin/sh', ''), 0, 0, None)

Version-Release number of selected component (if applicable):

firefox-23.0.1-3.fc20.x86_64

How reproducible:
Steps to Reproduce:
1. Try to create a livecd which installs firefox-23.0.1-3
2.
3.


Additional info:

Looking into the downloaded firefox-23.0.1-3 package (with mc) for the livecd shows that this version of firefox depends on xulrunner(x86-64) >= 23.0.1-1.

Complete listingfrom mc:

/bin/bash
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/bin/sh
/bin/sh
ld-linux-x86-64.so.2()(64bit)
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit)
libatk-1.0.so.0()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.17)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libc.so.6(GLIBC_2.3.2)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libcairo.so.2()(64bit)
libdl.so.2()(64bit)
libdl.so.2(GLIBC_2.2.5)(64bit)
libfontconfig.so.1()(64bit)
libfreetype.so.6()(64bit)
libgcc_s.so.1()(64bit)
libgdk-x11-2.0.so.0()(64bit)
libgdk_pixbuf-2.0.so.0()(64bit)
libgio-2.0.so.0()(64bit)
libglib-2.0.so.0()(64bit)
libgobject-2.0.so.0()(64bit)
libgtk-x11-2.0.so.0()(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libmozalloc.so()(64bit)
libnspr4.so()(64bit)
libpango-1.0.so.0()(64bit)
libpangocairo-1.0.so.0()(64bit)
libpangoft2-1.0.so.0()(64bit)
libplc4.so()(64bit)
libplds4.so()(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libstartup-notification-1.so.0()(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libxul.so()(64bit)
libxul.so(xul23.0.1)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
system-bookmarks
xulrunner(x86-64) >= 23.0.1-1
rpmlib(PayloadIsXz) <= 5.2-1


---

Regards,

DM
Comment 1 Dethlef Madsen 2013-09-02 08:54:07 EDT
The component magicly changed while creating the bug.

Sorry.
Comment 2 Dethlef Madsen 2013-09-04 12:29:13 EDT
May be a duplicate. livecd creation with qa-test-day works now


--- firefox-23.0.1-3.txt	2013-09-04 16:06:18.960559785 +0200
+++ firefox-23.0.1-4.txt	2013-09-04 16:04:22.837801180 +0200
@@ -4,7 +4,6 @@
 /bin/sh
 /bin/sh
 /bin/sh
-/bin/sh
 ld-linux-x86-64.so.2()(64bit)
 ld-linux-x86-64.so.2(GLIBC_2.3)(64bit)
 libatk-1.0.so.0()(64bit)
@@ -44,6 +43,7 @@
 libstdc++.so.6(GLIBCXX_3.4)(64bit)
 libxul.so()(64bit)
 libxul.so(xul23.0.1)(64bit)
+rpmlib(BuiltinLuaScripts) <= 4.2.2-1
 rpmlib(CompressedFileNames) <= 3.0.4-1
 rpmlib(FileDigests) <= 4.6.0-1
 rpmlib(PayloadFilesHavePrefix) <= 4.0-1

*** This bug has been marked as a duplicate of bug 1003691 ***

Note You need to log in before you can comment on or make changes to this bug.