Bug 1003602 - Lid close event not detected
Lid close event not detected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 896747 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 09:17 EDT by harlequix
Modified: 2014-03-15 11:24 EDT (History)
11 users (show)

See Also:
Fixed In Version: kernel-3.13.6-100.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 02:51:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harlequix 2013-09-02 09:17:51 EDT
Description of problem:
Lid state changes are not detected, /proc/acpi/button/lid/LID0/state always states open no matter if lid is closed or not.

faulty Hardware is unlikely since the screen is still switched of when closing the lid, so the hardware sensor still seems to work. Odly enough this bug also effects other distributions, tested on fedora 18 and ubuntu 13.04, havn't tried it on windows yet

Version-Release number of selected component (if applicable):
probably a kernel bug, running 3.10.10-200

How reproducible:


Steps to Reproduce:
1.close lid
2.ssh into laptop
3.check lid state

Actual results:
according to lid state it's still open

Expected results:
changing state to closed and executing configured actions e.g. suspending machine

Additional info:
Laptop: Samsung Series 5 540U3C A01
Comment 1 Josh Boyer 2013-09-18 16:51:42 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 2 harlequix 2013-09-22 18:53:24 EDT
Still persists on kernel 3.11.1
Comment 3 Kieran Clancy 2013-10-25 10:29:17 EDT
I have the same problem with my Samsung Series 9 NP900X3F.

Are you also running in UEFI?
Comment 4 Marcos Mello 2013-10-31 07:45:01 EDT
Similar problem here with a Lenovo ThinkPad Edge E430 (latest BIOS 2.54).

/proc/acpi/button/lid/LID0/state is "open" when I close the lid. But if I suspend using GNOME menu, close the lid and then open it, the laptop wakes up as it should.

What kind of debug information can we provide?

Fedora 19, kernel-3.11.6-200.fc19.x86_64, in UEFI mode.
Comment 5 harlequix 2013-11-29 02:27:59 EST
No it's running in UEFI, but Bios compatibility mode. Bug is still persisting by the way, but still havn't got around to test it on windows to rule out hardware damage(would be surprising considering the other bug reports). Will try to get to this weekend and hopefully report back soon
Comment 6 Justin M. Forbes 2014-01-03 17:08:19 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 7 Kieran Clancy 2014-01-06 02:24:55 EST
Still experiencing this with 3.12.6-200.fc19.x86_64.

See also: https://bugzilla.kernel.org/show_bug.cgi?id=45461
Comment 8 Kieran Clancy 2014-02-24 12:16:09 EST
The bad news is that this bug is still present in Fedora 20 - please update version.

The good news is that Juan Manuel Cabo has found a fix for this problem, and I have helped write it up as a kernel patch.

Refer to https://bugzilla.kernel.org/show_bug.cgi?id=44161#c125 from comments 125 onwards.

Is there any possibility of someone generating a kernel in koji with the patch there?
https://bugzilla.kernel.org/attachment.cgi?id=127161

I am happy to test it, but despite my best efforts I don't have enough hard drive space on this laptop to build the kernel. I tried three times to clear extra space and wait for rpmbuild to run, but each time it filled the drive. (Does the kernel really need 8GB+ to build in 2014? Wow.)
Comment 9 Josh Boyer 2014-02-24 15:22:17 EST
Nice work on that!  I'd suggest sending it upstream ASAP, even if it's only tested on a few machines.  Getting the code in front of the maintainers will allow you to respond to feedback while others are still testing it.
Comment 10 Kieran Clancy 2014-03-02 05:35:01 EST
Thanks for the encouragement to get it upstream, Josh. I have a lot more appreciation for the work that goes into that process now.

After a couple of revisions, it has now been accepted into the development branch of Rafael's linux-pm tree:

https://git.kernel.org/cgit/linux/kernel/git/rafael/linux-pm.git/commit/?id=27095111cbafd3212c7e9a4a8cef1099b7520ca8
Comment 11 Josh Boyer 2014-03-04 14:15:20 EST
Great!  We'll let this sit in linux-next for a bit and then look at doing a backport.
Comment 12 Mauro Carvalho Chehab 2014-03-07 03:13:41 EST
Hi Josh,

(In reply to Josh Boyer from comment #11)
> Great!  We'll let this sit in linux-next for a bit and then look at doing a
> backport.

This is a long known issue. We even have an old BZ, that were mistakenly opened against upower:
    https://bugzilla.redhat.com/show_bug.cgi?id=896747

I have two series 5 notebooks (NP540U3C and NP550P5C) here that suffers the same problem, and already did a backport of those patches.

I ran a scratchbuild with this patch applied, at:
   http://koji.fedoraproject.org/koji/taskinfo?taskID=6607977

If everything is ok, I'm intending to commit the backport, for us to be able to close this issue.
Comment 13 Josh Boyer 2014-03-07 07:48:25 EST
Hi Mauro, I had this queued for inclusion locally yesterday already.  Great minds think alike or something.

Kieran, once again great job and many thanks for pushing this through upstream.

Fixed in Fedora git.
Comment 14 Josh Boyer 2014-03-07 09:14:16 EST
*** Bug 896747 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2014-03-07 17:52:42 EST
kernel-3.13.6-100.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.13.6-100.fc19
Comment 16 Fedora Update System 2014-03-07 17:53:47 EST
kernel-3.13.6-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.13.6-200.fc20
Comment 17 Fedora Update System 2014-03-08 23:39:59 EST
Package kernel-3.13.6-100.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.13.6-100.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3651/kernel-3.13.6-100.fc19
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2014-03-10 02:51:06 EDT
kernel-3.13.6-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2014-03-15 11:24:41 EDT
kernel-3.13.6-100.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.