Bug 1003620 - RFE: Improve default xen blktap handling (requires libvirt changes)
RFE: Improve default xen blktap handling (requires libvirt changes)
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 09:38 EDT by Cole Robinson
Modified: 2015-09-23 17:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 17:36:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2013-09-02 09:38:21 EDT
See: https://bugzilla.redhat.com/show_bug.cgi?id=1003610

Libvirt should expose xen blktap support in capabilities XML so virt-manager can stop looking at /proc/modules.

Also, a xen user reported that with recent xen, driver_name=tap2 works but driver_name=tap doesn't:

http://www.redhat.com/archives/virt-tools-list/2013-June/msg00031.html

Might be worth investigating as well
Comment 1 Cole Robinson 2015-09-23 17:36:07 EDT
Just dropped explicit blktap support entirely since it's deprecated upstream:

commit 7c10d8a27f0f635c185d1b85d6d26120d51c8aa2
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed Sep 23 17:26:48 2015 -0400

    devicedisk: Tweak driver defaults for xen
    
    Following some discussion here:
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1171550
    
    jfehlig suggested better defaults for modern xen. End result is:
    
    - Drop the blktap check, since it's deprecated (yaay)
    - If xen + block device, use driver_name=phy
    - Otherwise if on modern enough libvirt + libxl, do the same thing we
      do for qemu.

Note You need to log in before you can comment on or make changes to this bug.