Bug 1003622 - New Item menu: Business Process always available
New Item menu: Business Process always available
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On:
Blocks: bpms6_ux/brms6_ux
  Show dependency treegraph
 
Reported: 2013-09-02 09:45 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no project selected, process menu item enabled (35.76 KB, image/png)
2013-09-02 09:45 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-02 09:45:01 EDT
Created attachment 792854 [details]
no project selected, process menu item enabled

Description of problem:
The New Item menu always has the Business Process enabled, even when no project is selected or even present in the repository.
If you try to create a process anyway, the 'Create new' dialogue has '<No Path selected>' at the bottom, with no way to select the path and clicking OK after setting a name for the process results in a popup with:

'Path in which to create new resource is missing. Please enter.'

If it is not possible to create a process at the current path, because no path is selected, the item shouldn't be available in the menu.

Also, please, correct that message.


Version-Release number of selected component (if applicable):
BRMS 6.0 ER2
Comment 2 Tihomir Surdilovic 2013-09-23 12:16:15 EDT
fixed in designer master and 6.0.x branches
Comment 3 Sona Mala 2013-10-16 05:49:21 EDT
Verified for ER4.

In empty repo, option "Business Process" is disabled.

Note You need to log in before you can comment on or make changes to this bug.