Bug 1003640 - grey BG instead of selected BG
grey BG instead of selected BG
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: light-themes (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohamed El Morabity
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 10:30 EDT by Gene Czarcinski
Modified: 2013-09-13 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: light-themes-13.04-0.2.20130412bzr283.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 22:29:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2013-09-02 10:30:08 EDT
Description of problem:
With the file manager (nautilus) handling the desktop on (org.gnome.desktop.background.show-desktop-icons is enabled) and this theme is selected for the Gtk+ theme, then the background is grey.  If the file manager is NOT handling the desktop, then the selected background is correctly displayed.

Note:  This is NOT the only theme with this problem.  So far as I cn tell, only the Adwaita, Zukitwo, and Zukiwi gtk3 themes do not have the problem.

Version-Release number of selected component (if applicable):
Fedora 19, gnome 3

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.

Actual results:
correct background displayed only if file manager not handling the desktop.

Expected results:
correct background displayed

Additional info:
Comment 1 Gene Czarcinski 2013-09-05 10:46:54 EDT
Apparently the rules changed.  The Adwaita theme was updated some time ago so it does not have the problem:

The themes probably needed to be updated because there was some change on the
gtk+ side. What makes me believe so are these changes which were made to
Adwaita (months before nautilus desktop changed):
https://git.gnome.org/browse/gnome-themes-standard/commit/?id=0019a41584317e73cdd3e3c06c8b2f0ce1978a21
https://git.gnome.org/browse/gnome-themes-standard/commit/?id=127d02f515dc5daa4e0af967c85030415dbf95e6

I would have thought that this interface change would have gotten more publicity.
Comment 2 Mohamed El Morabity 2013-09-05 11:01:04 EDT
Thanks for your bug report. The problem was reproduced, and a fix update will be available tonight in testing.
Comment 3 Fedora Update System 2013-09-05 15:17:36 EDT
light-themes-13.04-0.2.20130412bzr283.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/light-themes-13.04-0.2.20130412bzr283.fc19
Comment 4 Fedora Update System 2013-09-05 23:59:41 EDT
Package light-themes-13.04-0.2.20130412bzr283.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing light-themes-13.04-0.2.20130412bzr283.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15875/light-themes-13.04-0.2.20130412bzr283.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-13 22:29:44 EDT
light-themes-13.04-0.2.20130412bzr283.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.