Bug 1003647 - App Create Error: 'Cannot validate input uid'
App Create Error: 'Cannot validate input uid'
Status: CLOSED WORKSFORME
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On: 994683 1039641
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 10:38 EDT by Nikhil Mone
Modified: 2014-04-16 13:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 994683
Environment:
Last Closed: 2013-09-25 13:11:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikhil Mone 2013-09-02 10:38:15 EDT
+++ This bug was initially created as a clone of Bug #994683 +++

Description of problem:
We're sporadically getting this error when trying to create apps in PROD.

DEBUG: rhc app create -k -a 'd1308070951drupal' -t 'php-5.3' 
Application Options
-------------------
  Namespace:  openshiftnagios
  Cartridges: php-5.3
  Gear Size:  default
  Scaling:    no

Creating application 'd1308070951drupal' ... 
Unable to complete the requested operation due to: Cannot validate input uid: value should be a number.
Reference ID: 58852561d1deebdb2171df7fb28dd1e9
Reference ID: 58852561d1deebdb2171df7fb28dd1e9
DEBUG: rhc cartridge add -k -a 'd1308070951drupal' -c 'mysql-5.1' 
Adding mysql-5.1 to application 'd1308070951drupal' ... Application 'd1308070951drupal' not found.
Adding mysql-5.1 to application 'd1308070951drupal' ... Application 'd1308070951drupal' not found.
Exception: No such file or directory - /tmp/d20130807-2873-1mwdmsh/d1308070951drupal
/usr/local/lib/rhc_helper.rb:183:in `chdir'
/usr/local/lib/rhc_helper.rb:183:in `create_drupal'
/usr/local/bin/nagios-ctl-app:132:in `main'
/usr/local/bin/nagios-ctl-app:161
Connection to ex-srv1.prod.rhcloud.com closed.
Exit Code: 0



Version-Release number of selected component (if applicable):
We saw it in both 2.0.30 and after upgrading to 2.0.31.


How reproducible:
Very sporadic, only seen in PROD.

Steps to Reproduce:
1. unknown, just seen in PROD.


Actual results:
Sporadically fails with "Cannot validate input uid"


Expected results:
No error

--- Additional comment from Abhishek Gupta on 2013-08-15 18:41:59 EDT ---

Can you please provide the broker, mcollective and platform (node) logs for a request that fails with this error?

--- Additional comment from Abhishek Gupta on 2013-08-19 16:58:16 EDT ---

Snippet from the broker log --> pastebin.test.redhat.com/159283
Snippet from the mcollective log --> http://pastebin.test.redhat.com/159286

--- Additional comment from Abhishek Gupta on 2013-08-19 16:59:40 EDT ---

Providing snippets of logs from the broker and mcollective in the previous comment. Seems like useradd is failing because it is unable to lock /etc/passwd .

--- Additional comment from Mrunal Patel on 2013-08-19 17:13:03 EDT ---

Most likely some of these files were left behind by a crashing useradd/userdel operation.

/etc/passwd.lock
/etc/shadow.lock
/etc/group.lock
/etc/gshadow.lock

Note You need to log in before you can comment on or make changes to this bug.