Bug 1003648 - grey BG instead of selected BG
grey BG instead of selected BG
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluebird (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 10:38 EDT by Gene Czarcinski
Modified: 2013-09-06 01:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: bluebird-0.8-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 09:15:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix to correct getting grey background (570 bytes, patch)
2013-09-04 13:33 EDT, Gene Czarcinski
no flags Details | Diff

  None (edit)
Description Gene Czarcinski 2013-09-02 10:38:33 EDT
Description of problem:
With the file manager (nautilus) handling the desktop on (org.gnome.desktop.background.show-desktop-icons is enabled) and this theme is selected for the Gtk+ theme, then the background is grey.  If the file manager is NOT handling the desktop, then the selected background is correctly displayed.

Note:  This is NOT the only theme with this problem.  So far as I cn tell, only the Adwaita, Zukitwo, and Zukiwi gtk3 themes do not have the problem.

Version-Release number of selected component (if applicable):
Fedora 19, gnome 3

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.

Actual results:
correct background displayed only if file manager not handling the desktop.

Expected results:
correct background displayed

Additional info:
Comment 1 Miro Hrončok 2013-09-02 10:39:52 EDT
Isn't that a Nautilus bug instead?
Comment 2 Gene Czarcinski 2013-09-02 10:59:14 EDT
You raise an excellent question.  My answer is: I have no idea except that some themes work and some do not.  In addition to the one I list above, I have found that the "greybird" gtk3 theme works.  One theme (Zukini) has some code with comments that say it is suppose to address this problem ... but it does not.

I have not identified what "little thing" a theme is doing or not doing that is causing this grey background to occur.  The  correct fix may be to nautilus but first the real problem needs to be identified.

What surprises me is that nobody is noticed this previously.
Comment 3 Gene Czarcinski 2013-09-02 16:37:57 EDT
I am going to continue investigating the differences between greybird (which works) and bluebird (which does not).

Both are "noarch" and both claim to use "engine: none".  There are a lot of "little differences" and one of those "little differences" must be the cause of the grey background.  If anyone seeing this has an idea of where to look, please feel free to point me in a direction.
Comment 4 Miro Hrončok 2013-09-02 16:40:09 EDT
Try consulting with upstream.

https://github.com/shimmerproject/Bluebird/issues
Comment 5 Gene Czarcinski 2013-09-04 13:33:46 EDT
Created attachment 793759 [details]
fix to correct getting grey background

This patch does fix the problem of getting the grey background when nautilus is managing the desktop ... the selected background is not displayed.  This was done by comparing what greybird and bluebird did.

I do not know if this is a good fix or if there are other side effects.  I do not know why the theme worked fine under Fedora 18 but not under Fedora 19.  However, given this info, maybe someone more expert than myself can determine what the problem really is.
Comment 6 Miro Hrončok 2013-09-04 14:42:13 EDT
Will you try to push this upstream or should I do it?
Comment 7 Gene Czarcinski 2013-09-04 16:09:32 EDT
I would appreciate it if you could push this upstream as I am trying to handle a bunch of themes PLUS I really, really believe that the problem is NOT in the themes ... these themes worked just fine under Fedora 18 but (with no changes to the themes) they do not work on Fedora 19 ... of course Fedora 18 -> Fedora 19 also has nautilus 3.6.3 -> 3.8.2.  I tried to downgrade nautilus but that is easier said then done.

There have been three problem reports on this problem opened on the gnome bugzilla against nautilus and all were closed saying basically "not us" ... not clear to me that this is true.
Comment 8 Miro Hrončok 2013-09-04 16:45:15 EDT
The attached patch seems to be already included in 0.8. Have you tried to update first?
Comment 10 Miro Hrončok 2013-09-04 20:29:46 EDT
Still in testing, waits for your karma: https://admin.fedoraproject.org/updates/FEDORA-2013-15555/bluebird-0.8-1.fc19
Comment 11 Fedora Update System 2013-09-04 20:30:20 EDT
bluebird-0.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-15555/bluebird-0.8-1.fc19
Comment 12 Gene Czarcinski 2013-09-05 09:15:15 EDT
Got caught up with the same problem in multiple themes and did not notice that bluebird had identified and fixed the problem.

I am closing this as fixed in 0.8-1.fc19
Comment 13 Fedora Update System 2013-09-06 01:20:51 EDT
bluebird-0.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.