Bug 1003658 - Midori is not available as a choice of default browser in Gnome
Midori is not available as a choice of default browser in Gnome
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: midori (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 10:59 EDT by Randy Barlow
Modified: 2013-11-11 19:34 EST (History)
9 users (show)

See Also:
Fixed In Version: midori-0.5.5-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 22:35:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-09-02 10:59:33 EDT
Please add Midori as an option for default browser in Gnome. Thanks!
Comment 1 Kevin Fenzi 2013-09-02 12:34:33 EDT
Moving this over to control-center as I think thats where this can be set.
Comment 2 Kalev Lember 2013-09-07 20:42:41 EDT
On my F20 installation, Midori shows up fine in the gnome-control-center browser selection dialog:

http://kalev.fedorapeople.org/g-c-c-browser-selection-midori.png
Comment 3 Alexander Pánek 2013-11-05 21:19:35 EST
It doesn't work for me in F19. After a fresh install and installing Midori the settings dialog only gives me Firefox as option.
Comment 4 Bastien Nocera 2013-11-06 06:40:13 EST
(In reply to Kevin Fenzi from comment #1)
> Moving this over to control-center as I think thats where this can be set.

Hasn't for 3 years:
http://www.hadess.net/2010_10_01_archive.html

Does midori have "x-scheme-handler/http" and "x-scheme-handler/https" as mime-types it can handle?

Not a control-center bug anyway.
Comment 5 Kevin Fenzi 2013-11-06 11:14:04 EST
Yes, it does have those. I have no idea what the process beyond that is or where I could change anything in midori.
Comment 6 Alexander Pánek 2013-11-06 11:29:21 EST
Thank you Bastien for the link. It led me to a solution (albeit not a "good" one):

sudo vim /usr/share/applications/defaults.list -> %s/firefox/midori/g

A midori.desktop file is available and it has almost the same mimetype list as Firefox has - besides XUL.
Comment 7 Bastien Nocera 2013-11-06 12:30:45 EST
(In reply to Kevin Fenzi from comment #5)
> Yes, it does have those. I have no idea what the process beyond that is or
> where I could change anything in midori.

Running update-desktop-database in %post so that the mime-types are actually installed, to start with.
Comment 8 Kevin Fenzi 2013-11-06 12:46:30 EST
Cool. Thanks for politely pointing out that bug... updates on the way.
Comment 9 Fedora Update System 2013-11-06 13:01:24 EST
midori-0.5.5-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/midori-0.5.5-2.fc20
Comment 10 Fedora Update System 2013-11-06 13:28:40 EST
midori-0.5.5-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/midori-0.5.5-2.fc19
Comment 11 Fedora Update System 2013-11-06 22:31:45 EST
Package midori-0.5.5-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing midori-0.5.5-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20788/midori-0.5.5-2.fc19
then log in and leave karma (feedback).
Comment 12 Randy Barlow 2013-11-07 11:45:53 EST
Karma increased - thanks!
Comment 13 Alexander Pánek 2013-11-07 12:18:03 EST
Works for me now - left karma!
Comment 14 Fedora Update System 2013-11-08 22:35:16 EST
midori-0.5.5-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-11-11 19:34:20 EST
midori-0.5.5-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.