Bug 1003676 - Cannot reuse the existing partition layout when installing in text mode
Cannot reuse the existing partition layout when installing in text mode
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 12:42 EDT by Jean-Pierre André
Modified: 2013-10-03 16:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 16:01:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Pierre André 2013-09-02 12:42:47 EDT
Description of problem:

When installing in text mode, there is no possibility to force an existing partition layout

Version-Release number of selected component (if applicable):

Fedora 19, original release on Fedora-19-x86_64-DVD.iso

How reproducible:

Probably always (though did not retry)

Steps to Reproduce:

1. Use a computer whose graphic controller is not supported by the installer
2. Boot on the DVD, the graphic mode cannot be set and the installation goes on in text mode.
3. Select language, timezone, packages, etc. Then define the storage, and select an MBR partition layout.
4. You get three choices, approximately displayed as : use free space, use full space, and replace existing Linux installation.
5. Select the third option (the disk is full, and the partition layout had to be kept unchanged for Windows and OpenSolaris already installed, only Linux was to be replaced). Then type 'c' to continue.

Actual results:

The installer immediately redefines the partition layout and starts formatting the partitions. No validation sought.

Expected results:

The installer analyzes the layout of the existing Linux installation, displays a proposal and asks for any change or validation before partitioning or formatting.

Additional info:

I could not replay the scenario safely on a virtual machine. The only way to get the text installer is to have a failure while going into graphic mode.

In the troubleshooting menu there is an option for basic graphic mode, but this leads to bug #1003670
Comment 1 Steve Tyler 2013-09-02 13:16:35 EDT
(In reply to Jean-Pierre André from comment #0)
...
> I could not replay the scenario safely on a virtual machine. The only way to
> get the text installer is to have a failure while going into graphic mode.
...

Thanks for your report.

IIUC, you would rather install in graphical mode, but Bug 1003670 is preventing you from doing a graphical install, so you are using text mode as a work-around.

You can start the installer in text mode by appending "text" to the kernel command-line. To do that, press Tab at one of the installer boot menu items:

Install Fedora 19

Press Esc to cancel, Enter to boot.
Comment 2 Jean-Pierre André 2013-09-03 05:04:12 EDT
> IIUC, you would rather install in graphical mode, but Bug 1003670 is
> preventing you from doing a graphical install, so you are using text
> mode as a work-around.

I surely had rather install in graphical mode, but text mode was not a voluntary one. Rather, from the first choice "Install Fedora 19", the installer failed to set up graphical mode and went on in text mode. This appeared to be the only possibility.

But the point here is the installer went on modifying the partition without any validation from the user, when questions about the partition layout were expected. This is a disaster bug.

Please never go on partitioning or formatting existing partitions without prior positive agreement from the user ! Even in text mode ! When you type 'c' for continue, you do not know what comes next : maybe what you expect, maybe not !
Comment 3 Steve Tyler 2013-09-03 22:26:21 EDT
(In reply to Jean-Pierre André from comment #2)
> > IIUC, you would rather install in graphical mode, but Bug 1003670 is
> > preventing you from doing a graphical install, so you are using text
> > mode as a work-around.
> 
> I surely had rather install in graphical mode, but text mode was not a
> voluntary one. Rather, from the first choice "Install Fedora 19", the
> installer failed to set up graphical mode and went on in text mode. This
> appeared to be the only possibility.

OK. I apologize for my bad paraphrase of what you said in Comment 0: #1, #2.

> But the point here is the installer went on modifying the partition without
> any validation from the user, when questions about the partition layout were
> expected. This is a disaster bug.
> 
> Please never go on partitioning or formatting existing partitions without
> prior positive agreement from the user ! Even in text mode ! When you type
> 'c' for continue, you do not know what comes next : maybe what you expect,
> maybe not !

I did a test install in a VM with text mode, and I see what you mean.

After configuring everything, simply pressing 'c' causes the install to begin. This is in contrast with a graphical install, in which there is a Begin Installation button that must be pressed.

ISTM, there could be one extra step in the text install that says "By pressing 'c' now, the install will begin".

NB: While it is not very clear in text mode, no changes are made until installation begins. In graphical mode, there is a string below the Begin Installation button that says: "We won't touch your disks until you hit this button."

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-3.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 4 Jean-Pierre André 2013-09-04 03:07:27 EDT
Thank you Steve for analyzing the issue further.

> ISTM, there could be one extra step in the text install that says
> "By pressing 'c' now, the install will begin".

No. I had just selected "Replace existing Linux installation". At this stage I was expecting sda5 to be formatted, and I would have typed 'c'.

The warning should be either :
"By pressing 'c' now, the selected drive will be partitioned"
or (existing partitioning to be preserved)
"By pressing 'c' now, the partitions sda5 and sda7 will be formatted"
Comment 5 David Shea 2013-10-03 16:01:48 EDT
Text mode is only intended to provide a basic install environment. We are not going to support anything other than automatic partitioning in text mode.

The text mode fallback provides an option to use a VNC display for a graphical install, or you can use a kickstart file.

Note You need to log in before you can comment on or make changes to this bug.