Bug 1003685 - augtool fails to run in RHEL 7
augtool fails to run in RHEL 7
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Privoznik
Virtualization Bugs
:
: 1004162 1006358 (view as bug list)
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1003291
  Show dependency treegraph
 
Reported: 2013-09-02 14:08 EDT by Richard W.M. Jones
Modified: 2014-06-17 20:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:58:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix virtlockd augeas lens test (794 bytes, patch)
2013-09-03 10:24 EDT, Dominic Cleal
no flags Details | Diff

  None (edit)
Description Richard W.M. Jones 2013-09-02 14:08:34 EDT
Description of problem:

$ augtool 
Failed to initialize Augeas
error: Syntax error in lens definition
/usr/share/augeas/lenses/virtlockd.aug:3.0-.6:The module Libvirtd must be in a file named libvirtd.aug

Version-Release number of selected component (if applicable):

augeas-1.1.0-2.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install augeas.
2. Run 'augtool' command with no arguments.
3.

Actual results:

See above.

Expected results:

Should enter the shell.

Additional info:
Comment 1 Richard W.M. Jones 2013-09-02 14:13:33 EDT
Dominic points out this is a libvirt bug.  The following
patch should be backported:

http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=3e32544

I have libvirt-daemon-1.1.1-3.el7.x86_64
Comment 2 Dominic Cleal 2013-09-02 14:15:10 EDT
It looks like the test file wasn't updated in 3e32544 either.  Upstream it's still referring to Libvirtd.lns:

http://libvirt.org/git/?p=libvirt.git;a=blob;f=src/locking/test_virtlockd.aug.in;h=dcd47c38b600c753f9bede652f45ff2eb95bb9ec;hb=HEAD
Comment 3 Michal Privoznik 2013-09-03 10:18:53 EDT
(In reply to Dominic Cleal from comment #2)
> It looks like the test file wasn't updated in 3e32544 either.  Upstream it's
> still referring to Libvirtd.lns:
> 
> http://libvirt.org/git/?p=libvirt.git;a=blob;f=src/locking/test_virtlockd.
> aug.in;h=dcd47c38b600c753f9bede652f45ff2eb95bb9ec;hb=HEAD

And what should it be referring to?
Comment 4 Dominic Cleal 2013-09-03 10:24:59 EDT
Created attachment 793226 [details]
fix virtlockd augeas lens test

It should refer to Virtlockd.lns, which is the name of the module + lens in virtlockd.aug.

A quick test with augparse shows the Virtlockd module appears to pass the test still:
$ cp src/locking/test_virtlockd.aug{.in,}
$ augparse -I src/locking src/locking/test_virtlockd.aug
[ no output ]
Comment 6 Richard W.M. Jones 2013-09-04 05:25:30 EDT
*** Bug 1004162 has been marked as a duplicate of this bug. ***
Comment 7 Richard W.M. Jones 2013-09-05 17:10:04 EDT
Can we please fix this ASAP since it stops any builds of libguestfs.
Plus from Monday all bugs need 3 acks.
Comment 8 Luwen Su 2013-09-10 02:05:56 EDT
With
libvirt-1.1.1-4.el7.x86_64
augeas-1.1.0-2.el7.x86_64

# augtool
augtool> 

No error in log , so Verify this bug and clear the NEEDINFO.
Comment 9 Richard W.M. Jones 2013-09-10 12:08:13 EDT
*** Bug 1006358 has been marked as a duplicate of this bug. ***
Comment 10 Richard W.M. Jones 2013-09-13 09:52:47 EDT
Also works for me with libguestfs.
Comment 11 Ludek Smid 2014-06-13 06:58:58 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.