Bug 1003700 - rpmbuild of qpid-cpp-0.22-12 fails due to missing amqpc.so
rpmbuild of qpid-cpp-0.22-12 fails due to missing amqpc.so
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
3.0
All Linux
high Severity high
: 3.0
: ---
Assigned To: Irina Boverman
Stanislav Graf
: Regression, UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 16:50 EDT by Pavel Moravec
Modified: 2015-01-21 07:54 EST (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:54:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (164.55 KB, application/gzip)
2013-09-02 16:51 EDT, Pavel Moravec
no flags Details

  None (edit)
Description Pavel Moravec 2013-09-02 16:50:59 EDT
Description of problem:
Trying to rpmbuild from SRPM of qpid-cpp-0.22-12 fails due to missing amqpc.so


Version-Release number of selected component (if applicable):
qpid-cpp-0.22-12


How reproducible:
100%


Steps to Reproduce:
rm -rf ~/rpmbuild
mkdir ~/rpmbuild
mkdir ~/rpmbuild/SOURCES
cd ~/rpmbuild/SOURCES
wget http://download.devel.redhat.com/brewroot/////packages/qpid-cpp/0.22/12.el6/src/qpid-cpp-0.22-12.el6.src.rpm
rpm2cpio qpid-cpp-0.22-12.el6.src.rpm | cpio -div
rpmbuild -ba qpid-cpp.spec


Actual results:
RPM build errors:
    File not found: /root/rpmbuild/BUILDROOT/qpid-cpp-0.22-12.el6.x86_64/usr/lib64/qpid/client/amqpc.so


Expected results:
Build passes


Additional info:
Full build log attached.

qpid-cpp-0.22-4 can be built, since that there were some changes wrt. amqc.so in mrg.patch
Comment 1 Pavel Moravec 2013-09-02 16:51:30 EDT
Created attachment 792981 [details]
build log
Comment 2 Gordon Sim 2013-09-03 04:10:42 EDT
From the log:

> -- checking for module 'libqpid-proton'
> --   found libqpid-proton, version 0.4
> -- Qpid proton 0.4 is too old, require 0.5 - 0.5; amqp 1.0 support not enabled

I.e. the proton libs need to be updated. This dependency on specific versions is unfortunate but is due to a minor change in the proton protocol engine API. I think trying to handle both versions of that API through includes etc would actually lead to more confusion.
Comment 4 Pavel Moravec 2013-09-03 04:47:17 EDT
The cause in missing dependency version in spec file:

$ grep proton qpid-cpp.spec 
BuildRequires: qpid-proton-c
BuildRequires: qpid-proton-c-devel
$

While to build qpid-cpp, really qpid-proton-c-0.5 or higher is required (now with that version, my rpmbuild succeeds).

Irina, could you pls. confirm (and fix the spec file)?
Comment 6 Stanislav Graf 2014-01-31 09:42:34 EST
Verified on qpid-cpp-0.22-33.el6.src.rpm

From the spec file:
BuildRequires: qpid-proton-c-devel >= 0.6
--
* Tue Sep  3 2013 Irina Boverman <iboverma@redhat.com> - 0.22-13
- Changed qpid-proton... >= 0.5

Rebuild test passed on both i386 and x86_64.

Note You need to log in before you can comment on or make changes to this bug.