This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1003706 - can't add a printer
can't add a printer
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
19
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 19:12 EDT by Jim Haynes
Modified: 2014-06-18 10:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 10:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from the system-config-printer command as myself, administrator (1.67 KB, text/x-log)
2013-09-03 11:57 EDT, Jim Haynes
no flags Details
/var/log/cups/error_log (11.00 KB, text/plain)
2013-09-03 12:00 EDT, Jim Haynes
no flags Details

  None (edit)
Description Jim Haynes 2013-09-02 19:12:16 EDT
Description of problem:
Can't add a printer with system-config-printer

Version-Release number of selected component (if applicable):

system-config-printer-1.4.2-1.fc19.i686
How reproducible:
very

Steps to Reproduce:
1.Attempt to add a printer running system-config-printer
2.Gets to the panel where the printer name is chosen
3.punch "apply"

Actual results:
nothing happens, apply button stays active

Expected results:
Progress to add the printer and finish it up

Additional info:
System is F19 installed from Xfce spin and has firewalld disabled and
iptables installed

Running system-config-printer as administrative user, it never asks for
authentication.  Trying to run it as root gives 
(system-config-printer.py:4571): Gtk-WARNING **: cannot open display: :0.0
and returns to # prompt.
Comment 1 Jaromír Končický 2013-09-03 06:12:14 EDT
Please provide more information.
- Enable logging debug messages by editing /etc/cups/cupsd.conf, changing 'LogLevel' to 'debug'. 
- Run 'system-config-printer --debug' and try to add the printer again. Post the output.
- Post /var/log/cups/error_log
You can also try looking at https://fedoraproject.org/wiki/How_to_debug_printing_problems
Thanks.
Comment 2 Jim Haynes 2013-09-03 11:53:53 EDT
By not having firefox running I was able to run system-config-printer as root
Comment 3 Jim Haynes 2013-09-03 11:57:59 EDT
Created attachment 793254 [details]
output from the system-config-printer command as myself, administrator
Comment 4 Jim Haynes 2013-09-03 12:00:14 EDT
Created attachment 793255 [details]
/var/log/cups/error_log
Comment 5 Richard Shaw 2013-09-18 16:34:02 EDT
I'm having a similar problem. I didn't capture it but the only appearently helpful output from s-c-p --debug was "Printer disappeared" after I finished configuring. For me the add printer dialog didn't hang, it closed but no printer was actually added. It's worth mentioning though that I was using s-c-p from one computer and connecting to cups on another...
Comment 6 Tim Waugh 2013-11-18 08:15:05 EST
Jim: it looks like, rather than adding a printer, you tried deleting a printer. However, cupsd didn't get a request to actually carry out the delete-printer operation.

Did it ask you for your password?

What does this command say?:
pkcheck -a org.opensuse.cupspkhelper.mechanism.printeraddremove -p $$
Comment 7 Jim Haynes 2014-06-18 10:39:02 EDT
Close it - not running that version anymore.

Note You need to log in before you can comment on or make changes to this bug.