Bug 1003712 - [Regression] Bugzilla/Template.pm uses regex pattern that is not valid before perl 5.10
[Regression] Bugzilla/Template.pm uses regex pattern that is not valid before...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.4
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 21:13 EDT by Jason McDonald
Modified: 2014-10-12 18:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.4.0007
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 00:14:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason McDonald 2013-09-02 21:13:23 EDT
Description of problem:
The fix for Bug 919040 (backported from upstream) used the \h regex pattern, which was new in Perl 5.10.  The production servers are still using Perl 5.8.

Version-Release number of selected component (if applicable):
4.4.0007 (which was not deployed due to this bug).

How reproducible:
Always

Steps to Reproduce:
root@host bugzilla]# su apache -s /bin/bash -c ./rh-create-templates.pl
Unrecognized escape \h passed through at Bugzilla/Template.pm line 164.
Removing existing compiled templates...
Precompiling templates...done.
[root@host bugzilla]# service bugzilla-queue restart
Killing bugzilla-queue: [ OK ]
Starting bugzilla-queue: Unrecognized escape \h passed through at
Bugzilla/Template.pm line 164.

Actual results:
Perl error due to \h

Expected results:
No error.

Additional info:
none.
Comment 3 Simon Green 2013-09-05 20:03:15 EDT
This was backported to sprint7
Comment 4 Simon Green 2013-09-06 00:14:53 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.