Bug 1003716 - rpc.mountd -h: 1. In help info not include -r|--reverse-lookup; 2. And -H info format error.
Summary: rpc.mountd -h: 1. In help info not include -r|--reverse-lookup; 2. And -H inf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.1
Hardware: All
OS: Linux
high
low
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On: 1003713
Blocks: 1003715
TreeView+ depends on / blocked
 
Reported: 2013-09-03 01:47 UTC by JianHong Yin
Modified: 2016-11-04 04:59 UTC (History)
4 users (show)

Fixed In Version: nfs-utils-1.3.0-0.27.el7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1003713
Environment:
Last Closed: 2016-11-04 04:59:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description JianHong Yin 2013-09-03 01:47:19 UTC
+++ This bug was initially created as a clone of Bug #1003713 +++

Description of problem:
rpc.mountd -h:
1. In help info not include -r|--reverse-llokup; 
[root@dhcp-13-16 ~]# rpc.mountd -h 2>&1 
Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
	[-o num|--descriptors num] [-f exports-file|--exports-file=file]
	[-p|--port port] [-V version|--nfs-version version]
	[-N version|--no-nfs-version version] [-n|--no-tcp]
	[-H ha-callout-prog] [-s|--state-directory-path path]
	[-t num|--num-threads=num]
[root@dhcp-13-16 ~]# rpc.mountd -h 2>&1 | grep -- -r
[root@dhcp-13-16 ~]# man rpc.mountd | cat - | grep -- -r
       -r, --reverse-lookup

2. And -H info format error.
 should be [-H|--ha-callout prog]

Version-Release number of selected component (if applicable):
all nfs-utils version in  from RHEL5.9 RHEL5.10 RHEL6.x to RHEL7.0 ~

How reproducible:
y

Steps to Reproduce:
1. see the Description of problem:
2.
3.

Actual results:
rpc.mountd -h: 1. In help info not include -r|--reverse-llokup; 2. And -H info format error.

Expected results:
fix them

Additional info:

Comment 2 JianHong Yin 2013-09-03 02:03:17 UTC
suggest: please change the options info to same format:
[-x arg|--xxxxxx arg]
[-x arg|--xxxxxx arg|--xxxxxx=arg]

do not miss the arg.
I think that the product appearance is important too,

Comment 3 RHEL Program Management 2014-03-22 06:39:37 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 6 Steve Dickson 2016-01-20 17:10:27 UTC
commit 0bcc2bf2c71fce69961ffec6133988a0791bb07b
Author: Steve Dickson <steved@redhat.com>
Date:   Wed Jan 20 12:07:13 2016 -0500

    mountd: added missing argument to usage string

Comment 9 Yongcheng Yang 2016-05-18 08:24:17 UTC
(In reply to Steve Dickson from comment #6)
> commit 0bcc2bf2c71fce69961ffec6133988a0791bb07b
> Author: Steve Dickson <steved@redhat.com>
> Date:   Wed Jan 20 12:07:13 2016 -0500
> 
>     mountd: added missing argument to usage string

Revise the commit number:

commit 0c43a3e1ce8b2103e9c89aea0322367a22d6a491
Author: Steve Dickson <steved@redhat.com>
Date:   Wed Jan 20 12:07:13 2016 -0500

    mountd: added missing argument to usage string

Comment 14 Yongcheng Yang 2016-05-23 09:18:11 UTC
[root@ibm-x3550m4-02 rpc-mountd]# rpm -q nfs-utils
nfs-utils-1.3.0-0.27.el7.x86_64
[root@ibm-x3550m4-02 rpc-mountd]# rpc.mountd -h
Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
	[-o num|--descriptors num] [-f exports-file|--exports-file=file]
	[-p|--port port] [-V version|--nfs-version version]
	[-N version|--no-nfs-version version] [-n|--no-tcp]
	[-H prog |--ha-callout prog] [-r |--reverse-lookup]
	[-s|--state-directory-path path] [-g|--manage-gids]
	[-t num|--num-threads=num] [-u|--no-udp]
[root@ibm-x3550m4-02 rpc-mountd]# 

Move to VERIFIED and continue to run the automatic case.

Comment 16 errata-xmlrpc 2016-11-04 04:59:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.