Bug 1003759 - quota: setting limit on a single brick volume is not happening
quota: setting limit on a single brick volume is not happening
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
SATHEESARAN
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 03:09 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.33rhs-1
Doc Type: Bug Fix
Doc Text:
Previously, setting limits on a single brick volume or on a volume where all bricks reside on the same node, in a cluster with more than one node, failed due to the incorrect aggregation logic for quota sub command. Now, with this update setting limits is successful.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:36:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-09-03 03:09:07 EDT
Description of problem:
setting quota limit on a single volume results to a failure,

[root@nfs1 glusterfs-test]# gluster volume status dist
Status of volume: dist
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick 10.70.37.213:/rhs/bricks/dist			49158	Y	11315
NFS Server on localhost					2049	Y	11328
Quota Daemon on localhost				N/A	Y	11396
NFS Server on 10.70.37.145				2049	Y	10227
Quota Daemon on 10.70.37.145				N/A	Y	10269
NFS Server on 10.70.37.76				2049	Y	10205
Quota Daemon on 10.70.37.76				N/A	Y	10248
NFS Server on 10.70.37.68				2049	Y	10282
Quota Daemon on 10.70.37.68				N/A	Y	10322
 
There are no active volume tasks


Version-Release number of selected component (if applicable):
[root@nfs2 ~]# rpm -qa | grep glusterfs
glusterfs-geo-replication-3.4.0.30rhs-2.el6rhs.x86_64
samba-glusterfs-3.6.9-160.3.el6rhs.x86_64
glusterfs-libs-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-server-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-rdma-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-api-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-fuse-3.4.0.30rhs-2.el6rhs.x86_64

How reproducible:
seen on this build

Steps to Reproduce:
1. create single brick volume, start it
2. enable quota
3. try setting some quota limit

Actual results:
[root@nfs1 glusterfs-test]# gluster volume quota dist limit-usage / 1GB
quota command failed : Failed to get trusted.gfid attribute on path /. Reason : No such file or directory

Expected results:
limit set should be allowed

Additional info:
Comment 4 SATHEESARAN 2013-10-07 07:37:56 EDT
Verified with RHS 2.1 ( glusterfs-3.4.0.33rhs-1 )

Steps
=====
1. Created the volume with single brick

[root@rhs5 ~]# gluster volume status
 
Status of volume: simple
Gluster process                                         Port    Online  Pid
------------------------------------------------------------------------------
Brick 10.70.37.95:/rhs/brick1/dir2                      49153   Y       24823
NFS Server on localhost                                 2049    Y       25317
Quota Daemon on localhost                               N/A     Y       25911
NFS Server on 10.70.37.155                              2049    Y       2187
Quota Daemon on 10.70.37.155                            N/A     Y       3714

2. NFS mount the volume
(i.e) mount -t nfs 10.70.37.95:simple /mnt
[root@rhs-gp-srv10 master]# df -Th /mnt
Filesystem    Type    Size  Used Avail Use% Mounted on
10.70.37.95:simple
               nfs    100G  288M  100G   1% /mnt

3. Set the quota on the root of glusterfs volume
[root@rhs5 ~]# gluster volume quota simple limit-usage /master 1GB
volume quota : success

4. Did some IO on NFS mount as well as fuse mount

[root@rhs5 ~]# gluster volume quota simple list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/master                                    1.0GB       80%     348.2MB 675.8MB

Moving it to VERIFIED
Comment 5 errata-xmlrpc 2013-11-27 10:36:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.