Bug 1003776 - SELinux is preventing /usr/bin/lsmd from 'write' accesses on the directory ipc.
SELinux is preventing /usr/bin/lsmd from 'write' accesses on the directory ipc.
Status: CLOSED DUPLICATE of bug 1002903
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
abrt_hash:941e8d1ad8de37f5ddecfb87269...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 03:50 EDT by Gerd Hoffmann
Modified: 2014-07-09 11:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 08:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2013-09-03 03:50:35 EDT
Description of problem:
SELinux is preventing /usr/bin/lsmd from 'write' accesses on the directory ipc.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that lsmd should be allowed write access on the ipc directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep lsmd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:lsmd_t:s0
Target Context                system_u:object_r:var_run_t:s0
Target Objects                ipc [ dir ]
Source                        lsmd
Source Path                   /usr/bin/lsmd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           libstoragemgmt-0.0.22-2.el7.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.el7.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-10.el7.x86_64 #1 SMP Tue
                              Aug 20 16:54:38 EDT 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-30 12:22:16 CEST
Last Seen                     2013-08-30 12:22:16 CEST
Local ID                      9c4f7882-d549-4ccd-a033-8b0505079e2a

Raw Audit Messages
type=AVC msg=audit(1377858136.466:18): avc:  denied  { write } for  pid=673 comm="lsmd" name="ipc" dev="tmpfs" ino=15040 scontext=system_u:system_r:lsmd_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=dir


type=SYSCALL msg=audit(1377858136.466:18): arch=x86_64 syscall=access success=no exit=EACCES a0=40262c a1=6 a2=0 a3=8 items=0 ppid=1 pid=673 auid=4294967295 uid=994 gid=994 euid=994 suid=994 fsuid=994 egid=994 sgid=994 fsgid=994 tty=(none) ses=4294967295 comm=lsmd exe=/usr/bin/lsmd subj=system_u:system_r:lsmd_t:s0 key=(null)

Hash: lsmd,lsmd_t,var_run_t,dir,write

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.0-10.el7.x86_64
type:           libreport
Comment 2 Milos Malik 2013-09-03 08:02:47 EDT
I believe this bug is a duplicate of BZ#1002903.
Comment 3 Miroslav Grepl 2013-09-03 08:36:09 EDT

*** This bug has been marked as a duplicate of bug 1002903 ***

Note You need to log in before you can comment on or make changes to this bug.