Bug 1003807 - Dist-geo-rep: If a single slave node to which all the master nodes do aux mount goes down , all geo-rep status goes to Faulty.
Dist-geo-rep: If a single slave node to which all the master nodes do aux mou...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Csaba Henk
:
Depends On: 980049 1002614
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 05:21 EDT by Venky Shankar
Modified: 2014-04-17 07:47 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 980049
Environment:
Last Closed: 2014-04-17 07:47:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-03 06:06:23 EDT
REVIEW: http://review.gluster.org/5759 (geo-replication: fix the logic of choosing the remote node to sync) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 2 Anand Avati 2013-09-03 06:07:19 EDT
REVIEW: http://review.gluster.org/5761 (gsyncd / geo-rep: distributify slave) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 3 Anand Avati 2013-09-04 23:56:32 EDT
COMMIT: http://review.gluster.org/5759 committed in master by Anand Avati (avati@redhat.com) 
------
commit eebd4e14853b1660ccf520f4ee34729d2b118878
Author: Venky Shankar <vshankar@redhat.com>
Date:   Wed Aug 28 01:33:11 2013 +0530

    geo-replication: fix the logic of choosing the remote node to sync
    
    Change-Id: Ie15636357d89e94b6bfad0e168b1fcad53508c47
    BUG: 1003807
    Signed-off-by: Amar Tumballi <amarts@redhat.com>
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5759
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 Anand Avati 2013-09-04 23:57:54 EDT
COMMIT: http://review.gluster.org/5761 committed in master by Anand Avati (avati@redhat.com) 
------
commit 85c2b2de12e98a8cce34277541df8c5c511e7231
Author: Venky Shankar <vshankar@redhat.com>
Date:   Thu Aug 29 22:57:44 2013 +0530

    gsyncd / geo-rep: distributify slave
    
    commit fbb8fd92 introduced slave distributification but had
    some problems (monitor would crash upon gsyncd start). This
    patch fixes the issue and makes code more pythonic ;)
    
    Change-Id: I2cbf5669d81966046a4aeeb4a6ad11a947aa8f09
    BUG: 1003807
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-on: http://review.gluster.org/5761
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 5 Niels de Vos 2014-04-17 07:47:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.