Bug 1003851 - DHT - after adding brick/s, layout for root directory is getting changed (without running rebalance) so files created on mount point after adding bricks are distributed to new brick/sub-volume also
DHT - after adding brick/s, layout for root directory is getting changed (wit...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 921408 950314
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 07:26 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 950314
Environment:
Last Closed: 2014-04-17 09:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-03 07:28:23 EDT
REVIEW: http://review.gluster.org/5762 (cluster/dht: Fix anomaly check) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-09-10 02:14:27 EDT
REVIEW: http://review.gluster.org/5762 (cluster/dht: Fix anomaly check) posted (#3) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 3 Anand Avati 2013-09-23 14:41:18 EDT
COMMIT: http://review.gluster.org/5762 committed in master by Anand Avati (avati@redhat.com) 
------
commit 711484d759cedbd77e449d306f7e31d596e6ae0d
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue Sep 3 09:13:21 2013 +0000

    cluster/dht: Fix anomaly check
    
    We were wrongly detecting holes/overlaps for already accounted
    errors. Additionally, sort should also handle zero'ed out layout
    
    Change-Id: Ic3d13e1d735b914f9acc01fe919bc90656baea48
    BUG: 1003851
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5762
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 6 Anand Avati 2013-12-10 04:20:22 EST
REVIEW: http://review.gluster.org/6469 (cluster/dht: Fix anomaly check) posted (#1) for review on release-3.4 by Shishir Gowda (gowda.shishir@gmail.com)
Comment 7 Anand Avati 2013-12-14 09:25:29 EST
COMMIT: http://review.gluster.org/6469 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 790c2813ef4898b28ebae8545c8d891ac4114bf1
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue Sep 3 09:13:21 2013 +0000

    cluster/dht: Fix anomaly check
    
    We were wrongly detecting holes/overlaps for already accounted
    errors. Additionally, sort should also handle zero'ed out layout
    
    Change-Id: Ic3d13e1d735b914f9acc01fe919bc90656baea48
    BUG: 1003851
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5762
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/6469
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 09:14:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.