Bug 1003867 - systemd is not able solve two (or more?) swap partitions activation correctly
systemd is not able solve two (or more?) swap partitions activation correctly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 1009291 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 07:52 EDT by Frantisek Hanzlik
Modified: 2014-10-14 20:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 20:13:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2013-09-03 07:52:14 EDT
Description of problem:
Having two swap partitions on two disk drives, systemd activate them, but repeatedly tried activate one, generate lot of error log messages, and boot take a long time. Note 'dev-sdb3.swap   loaded failed failed    /dev/sdb3' in listing below:
# systemctl --full --all --type=swap
UNIT                                                                               LOAD   ACTIVE   SUB    JOB   DESCRIPTION
dev-disk-by\x2did-ata\x2dWDC_WD1502FAEX\x2d007BA0_WD\x2dWMAY02707524\x2dpart3.swap loaded active   active       /dev/disk/by-id/ata-WDC_WD1502FAEX-007BA0_WD-WMAY02707524-part3
dev-disk-by\x2did-ata\x2dWDC_WD1502FAEX\x2d007BA0_WD\x2dWMAY03109541\x2dpart3.swap loaded inactive dead   start /dev/disk/by-id/ata-WDC_WD1502FAEX-007BA0_WD-WMAY03109541-part3
dev-disk-by\x2did-wwn\x2d0x50014ee0584b373e\x2dpart3.swap                          loaded inactive dead   start /dev/disk/by-id/wwn-0x50014ee0584b373e-part3
dev-disk-by\x2did-wwn\x2d0x50014ee6ac15a17d\x2dpart3.swap                          loaded active   active       /dev/disk/by-id/wwn-0x50014ee6ac15a17d-part3
dev-disk-by\x2dlabel-swap\x2da.swap                                                loaded active   active       /dev/disk/by-label/swap-a
dev-disk-by\x2dlabel-swap\x2db.swap                                                loaded inactive dead   start /dev/disk/by-label/swap-b
dev-disk-by\x2dpartlabel-Linux\x5cx20swap.swap                                     loaded active   active       /dev/disk/by-partlabel/Linux\x20swap
dev-disk-by\x2dpartuuid-3413bdb8\x2d3333\x2d46a7\x2dacac\x2dcdc78cfeba5c.swap      loaded inactive dead   start /dev/disk/by-partuuid/3413bdb8-3333-46a7-acac-cdc78cfeba5c
dev-disk-by\x2dpartuuid-73029b39\x2dcf4d\x2d400b\x2d909d\x2d9febb281f679.swap      loaded active   active       /dev/disk/by-partuuid/73029b39-cf4d-400b-909d-9febb281f679
dev-disk-by\x2duuid-299ca22b\x2d5ac3\x2d413e\x2d8111\x2d6f9c2af1a3c1.swap          loaded active   active       /dev/disk/by-uuid/299ca22b-5ac3-413e-8111-6f9c2af1a3c1
dev-disk-by\x2duuid-2fea3af7\x2da27b\x2d4686\x2d934e\x2dacf4c1830642.swap          loaded active   active       /dev/disk/by-uuid/2fea3af7-a27b-4686-934e-acf4c1830642
dev-sda3.swap                                                                      loaded active   active       /dev/sda3
dev-sdb3.swap                                                                      loaded failed   failed       /dev/sdb3

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
JOB    = Pending job for the unit.

13 loaded units listed.


# blkid|grep swap
/dev/sda3: UUID="9cb870b2-b5fa-46b5-b5b1-a2aa01b1216a" TYPE="swap" PARTLABEL="Linux swap" PARTUUID="adf83831-8528-44e8-a7f0-7b3109cfcbb8" 
/dev/sdb3: UUID="f41213ac-da73-459f-b2e7-0f356305b8b1" TYPE="swap" PARTLABEL="Linux swap" PARTUUID="adf83831-8528-44e8-a7f0-7b3109cfcbb8" 

# LANG=C swapon -s -v
Filename                   Type            Size    Used    Priority
/dev/sdb3                  partition       3145724 1564    -1
/dev/sda3                  partition       3145724 0       -2

# grep swap /etc/fstab
UUID=299ca22b-5ac3-413e-8111-6f9c2af1a3c1 swap  swap   defaults   0 0
UUID=2fea3af7-a27b-4686-934e-acf4c1830642 swap  swap   defaults   0 0


Version-Release number of selected component (if applicable):
systemd-201-2.fc18.7.i686
systemd-204-9.fc19.i686

How reproducible:
I tried this on three different PCs, on all of them are same this bad behavior.
Comment 1 Zbigniew Jędrzejewski-Szmek 2013-10-06 16:29:42 EDT
*** Bug 1009291 has been marked as a duplicate of this bug. ***
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-10-10 09:27:41 EDT
*** Bug 1017509 has been marked as a duplicate of this bug. ***
Comment 3 Zbigniew Jędrzejewski-Szmek 2013-12-08 19:51:31 EST
This should be fixed in http://cgit.freedesktop.org/systemd/systemd/commit/?id=9670d58. Unfortunately it won't be easy to backport.
Comment 4 Fedora Update System 2013-12-08 22:37:45 EST
systemd-204-18.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-18.fc19
Comment 5 Zbigniew Jędrzejewski-Szmek 2013-12-08 22:39:27 EST
Nevermind.
Comment 6 Zbigniew Jędrzejewski-Szmek 2014-10-14 20:13:12 EDT
Sorry, will not backport the fix.

Note You need to log in before you can comment on or make changes to this bug.