Bug 1003869 - engine-backup --mode=restore fails on unrecognized option
engine-backup --mode=restore fails on unrecognized option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Ofer Schreiber
movciari
integration
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-09-03 07:59 EDT by movciari
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: is15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:19:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18964 None None None Never

  None (edit)
Description movciari 2013-09-03 07:59:25 EDT
Description of problem:
engine-backup --mode=restore tries to check md5sum with "--strict" option, which works for fedora but fails for RHEL 6 because md5sum on RHEL does not have this option yet

Restoring...
md5sum: unrecognized option '--strict'
Try `md5sum --help' for more information.
FATAL: Checksum verification failed

Version-Release number of selected component (if applicable):
3.3.0-0.18 (is12)

How reproducible:
Always on RHEL 6

Steps to Reproduce:
1. create engine backup with engine-backup utility
(engine-backup --mode=backup --scope=all --log=/tmp/log --file=backupfile)
2. try to restore engine from this backup
(engine-backup --mode=backup --scope=all --log=/tmp/log --file=backupfile)
3. you will get an error

Actual results:


Expected results:


Additional info:

PRD: https://bugzilla.redhat.com/show_bug.cgi?id=960280
Comment 1 Itamar Heim 2014-01-21 17:19:08 EST
Closing - RHEV 3.3 Released
Comment 2 Itamar Heim 2014-01-21 17:25:20 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.