Bug 1003910 - Needinfo adds the target user to the CC list
Needinfo adds the target user to the CC list
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 09:44 EDT by Radek Bíba
Modified: 2013-09-04 02:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 21:11:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2013-09-03 09:44:40 EDT
Description of problem:
Not sure which roles are affected. In my case, I set needinfo from the reporter and Bugzilla added them to the CC list. Why? Reporters get all comments automatically, don't they? This is unnecessary, not to mention that it's not very nice when software does things on my behalf that I didn't intentionally do.

Additional info:
https://bugzilla.redhat.com/show_activity.cgi?id=784565 (search for my login). The e-mail that was sent to me also contains:

                 CC|                            |THE@USER.com
              Flags|                            |needinfo?(THE@USER.co
                   |                            |m)
Comment 1 Simon Green 2013-09-03 21:11:29 EDT
Been set as the requestee on a flag will CC: that user on the bug if they have the "Automatically add me to the CC list of bugs I am requested to review" turned on. This is on by default in upstream Bugzilla and Red Hat Bugzilla. It makes no difference what relationship you or the requestee user currently have to the bug.

If a user has an issue with this, their best course of action would be to change this preference in their settings. (FWIW, I have this option disabled in my preferences)

  -- simon
Comment 2 Radek Bíba 2013-09-04 02:30:20 EDT
Well, then it's a strange new feature with questionable default settings. Shouldn't BZ ask me if I want to CC the user at the same time? Or, shouldn't it consider the reporter (and QA contact) a special case?
Comment 3 Simon Green 2013-09-04 02:45:38 EDT
(In reply to Radek Bíba from comment #2)
> Shouldn't BZ ask me if I want to CC the user at the same time?

No, it definitely should be up to the user (the requestee) to decide if they want to be CC:ed on the bug, not the person making the change (the requester).

> Or, shouldn't
> it consider the reporter (and QA contact) a special case?

No, it shouldn't, for the reason stated above.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.