Bug 1003922 - openssh update kills sshd daemon with FATAL FIPS SELFTEST FAILURE
openssh update kills sshd daemon with FATAL FIPS SELFTEST FAILURE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openssl (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Mraz
Hubert Kario
:
Depends On: 1003296
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 10:10 EDT by Colin Walters
Modified: 2013-11-21 04:24 EST (History)
6 users (show)

See Also:
Fixed In Version: openssl-1.0.1e-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003296
Environment:
Last Closed: 2013-11-21 04:24:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2013-09-03 10:10:08 EDT
A rawhide update replacing openssh-6.2p2-5.fc20.x86_64 packages with those for openssh-6.2p2-6.1.fc21.x86_64 produced the following in logs:

sshd: fips.c(137): OpenSSL internal error, assertion failed: FATAL FIPS SELFTEST FAILURE

I get this with openssl-1.0.1e-9.el6 too.
Comment 1 Tomas Mraz 2013-09-03 10:20:28 EDT
This should be fixed with latest openssl packages.
openssl-1.0.1e-19.fc21
openssl-1.0.1e-10.el6
Comment 5 errata-xmlrpc 2013-11-21 04:24:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1585.html

Note You need to log in before you can comment on or make changes to this bug.