Bug 1003972 - Dhcp4 part of Bind10 not binding to interface.
Dhcp4 part of Bind10 not binding to interface.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind10 (Show other bugs)
19
i686 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 11:20 EDT by Eric Teeter
Modified: 2013-11-10 02:42 EST (History)
3 users (show)

See Also:
Fixed In Version: bind10-1.1.0-10.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:42:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Teeter 2013-09-03 11:20:09 EDT
When I tried to install dhcp4 on bind10:

> config add Init/components b10-dhcp4
> config set Init/components/b10-dhcp4/kind dispensable
> config commit

then tried to see if it was working:

> config show Dhcp4
>

I get no responce so I check the log and found the following: 


 INFO  [b10-init.init/6648] BIND10_COMPONENT_START component b10-dhcp4 is starting
 INFO  [b10-init.init/6648] BIND10_STARTING_PROCESS starting process b10-dhcp4
 INFO  [b10-dhcp4.dhcp4/6736] DHCP4_STARTING server starting
 ERROR [b10-dhcp4.dhcp4/6736] DHCP4_SRV_CONSTRUCT_ERROR error creating Dhcpv4Srv object, reason: Failed to set SO_BINDTODEVICE option on socket 4
 INFO  [b10-dhcp4.dhcpsrv/6736] DHCPSRV_MEMFILE_DB opening memory file lease database: type=memfile
 WARN  [b10-dhcp4.dhcpsrv/6736] DHCPSRV_MEMFILE_WARNING using early version of memfile lease database - leases will be lost after a restart
 INFO  [b10-dhcp4.dhcp4/6736] DHCP4_CONFIG_COMPLETE DHCPv4 server has completed configuration:
 INFO  [b10-dhcp4.dhcp4/6736] DHCP4_SHUTDOWN server shutdown

Which tells me that you need to bind a interface before it will work and none of the guides show how to do this. 

If just one interface should the component find it on it own? If more than one then have to specify. 



This is just a manual problem, is there a place that list Iint/components that can be added and all options that go with.
Comment 1 Jiri Popelka 2013-09-03 12:05:05 EDT
(In reply to Eric Teeter from comment #0)
> Dhcpv4Srv object, reason: Failed to set SO_BINDTODEVICE option on socket 4

> Which tells me that you need to bind a interface before it will work and
> none of the guides show how to do this. 

To me this seems more like a bug then a configuration problem.
AFAIK DHCPv4 code is far from any usable state.
Comment 2 Eric Teeter 2013-09-03 12:22:03 EDT
(In reply to Jiri Popelka from comment #1)
> (In reply to Eric Teeter from comment #0)
> > Dhcpv4Srv object, reason: Failed to set SO_BINDTODEVICE option on socket 4
> 
> > Which tells me that you need to bind a interface before it will work and
> > none of the guides show how to do this. 
> 
> To me this seems more like a bug then a configuration problem.
> AFAIK DHCPv4 code is far from any usable state.

Your saying that I can not configure the interface for Dhcp4 to listen on. The old version makes you set the interface of you have more than one. I thought that if you had only one it choose that one it own.

This computer has only one interface.
Comment 3 Eric Teeter 2013-09-04 15:17:48 EDT
Jiri:

While you at it DHCP6 gives the following error:

ERROR [b10-dhcp6.dhcp6/8426] DHCP6_SRV_CONSTRUCT_ERROR error creating Dhcpv6Srv object, reason: Failed to bind socket 4 to fe80::20e:7fff:fef3:aee9/port=547
Comment 4 Tomáš Hozza 2013-09-26 08:09:37 EDT
Hi.

This looks more like a bug.

Reported upstream -> http://bind10.isc.org/ticket/3176
Comment 5 Tomáš Hozza 2013-10-08 10:14:15 EDT
I found out that the problem seems to be caused by using the "-u" option when
starting the bind10.

In the meanwhile as a workaround you can modify the bind10.service file not to
use it (remove the "-u named" part from the ExecStart line.
Comment 6 Tomáš Hozza 2013-10-09 03:23:49 EDT
After discussion with upstream [1] it seems that the only solution at the
moment is to run BIND10 as root. I made the necessary changes and will push
an update.

To sum up the problem:
At the moment DHCP servers create sockets by themselves, however if BIND10 is 
not run as a root, these processes don't have permissions to set some socket
options (as SO_BINDTODEVICE). They should use b10-socketcreator to create
sockets, however we can not expect upstream to fix this any time soon. They have
different priorities at the moment. From what I checked it is not really trivial.

[1] https://lists.isc.org/pipermail/bind10-dhcp/2013-October/000043.html
Comment 7 Fedora Update System 2013-10-09 03:38:12 EDT
bind10-1.1.0-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/bind10-1.1.0-5.fc19
Comment 8 Fedora Update System 2013-10-09 03:39:37 EDT
bind10-1.1.0-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bind10-1.1.0-9.fc20
Comment 9 Fedora Update System 2013-10-09 21:01:35 EDT
Package bind10-1.1.0-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bind10-1.1.0-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18637/bind10-1.1.0-5.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-18 15:51:10 EDT
bind10-1.1.0-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-10-24 13:45:49 EDT
Package bind10-1.1.0-10.fc20, log4cplus-1.1.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bind10-1.1.0-10.fc20 log4cplus-1.1.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18737/bind10-1.1.0-10.fc20,log4cplus-1.1.2-1.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-11-10 02:42:01 EST
bind10-1.1.0-10.fc20, log4cplus-1.1.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.