Bug 1003982 - RTGOV Server fails to start when layered on top of EAP due to missing switchyard dependencies
RTGOV Server fails to start when layered on top of EAP due to missing switchy...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: ---
Assigned To: Gary Brown
Andrej Vano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 11:53 EDT by George Varsamis
Modified: 2014-07-02 05:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-261 Major Closed RTGov server profile cannot be installed in EAP without switchyard 2018-01-11 00:39 EST

  None (edit)
Description George Varsamis 2013-09-03 11:53:42 EDT
Description of problem:
When RTGOV Server is layered on top of EAP 6 it fails to start due to missing dependencies. The error is:

16:06:45,074 INFO  [org.jboss.as.messaging] (ServerService Thread Pool -- 55) JBAS011601: Bound messaging object to jndi name java:/ConnectionFactory
16:06:45,079 INFO  [org.jboss.as.messaging] (ServerService Thread Pool -- 53) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
16:06:45,115 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC000001: Failed to start service jboss.module.service."deployment.overlord-rtgov.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.overlord-rtgov.war".main: JBAS018759: Failed to load module: deployment.overlord-rtgov.war:main
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:92) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_09-icedtea]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_09-icedtea]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_09-icedtea]
Caused by: org.jboss.modules.ModuleNotFoundException: org.switchyard.bus.camel:main
        at org.jboss.modules.Module.addPaths(Module.java:949) [jboss-modules.jar:1.2.0.Final-redhat-1]
        at org.jboss.modules.Module.link(Module.java:1304) [jboss-modules.jar:1.2.0.Final-redhat-1]
        at org.jboss.modules.Module.relinkIfNecessary(Module.java:1332) [jboss-modules.jar:1.2.0.Final-redhat-1]
        at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:226) [jboss-modules.jar:1.2.0.Final-redhat-1]
        at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:71) [jboss-as-server-7.2.0.Final-redhat-8.jar:7.2.0.Final-redhat-8]
        ... 5 more
 
====================================
 
Checking the Dependencies for overlord-rtgov:
grep camel standalone/deployments/overlord-rtgov/overlord-rtgov.war/META-INF/maven/org.overlord.rtgov.release.jbossas/overlord-rtgov/pom.xml
 
<Dependencies>org.overlord.rtgov export services, org.picketbox, org.picketlink, org.jboss.as.web, org.switchyard.bus.camel, org.switchyard.api, org.apache.camel.core, org.switchyard.api.extensions.java, org.switchyard.api.extensions.wsdl, org.switchyard.security, org.switchyard.runtime, org.switchyard.component.bpel, org.drools</Dependencies>
 
l modules/system/layers/soa/org/
total 8
drwxrwxr-x. 3 gvarsami gvarsami 4096 Aug 29 16:57 mvel/
drwxrwxrwx. 4 gvarsami gvarsami 4096 Sep  3 07:25 overlord/

It is clear that we are missing those dependencies from modules.

Given on how much of switchyard is needed, is this a valid combination EAP+RTGOV Server ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Gary Brown 2013-09-03 12:04:44 EDT
The main reason for the dependencies is for when the server is embedded with a switchyard environment. However the server technically can run without switchyard, so the EAP+RTGov configuration is valid.

There are a couple of issues:

1) The switchyard dependencies in the manifest need to be made optional, which is easy enough.

2) The drools dependency is required - so this will need to be included in the configuration, e.g. EAP+Drools+MVEL+RTGov Server. This is probably a productisation issue?

3) The event listener registration is dependent upon the switchyard classes - so I need handle that.

So will work on making the changes for (1) and (3), but need feedback from productisation on (2).
Comment 2 George Varsamis 2013-09-03 12:06:31 EDT
We can do (2). I'll try and do this tonight, or early tomorrow morning.
Comment 3 Gary Brown 2013-09-04 03:58:25 EDT
Tested deployment to EAP - but manually had to move the overlord modules from soa layer to base, and also had to add the org.drools module into base.

NOTE: Fix has been committed to product branch, which also has three (I believe) additional fixes since the ER2 tag. Should I move the ER2 tag, so that all recent fixes are included?
Comment 4 JBoss JIRA Server 2013-09-04 03:58:50 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-261 to Resolved
Comment 5 George Varsamis 2013-09-04 10:04:38 EDT
I can confirm that this fix works and can now be set as resolved.
Comment 6 Andrej Vano 2013-09-18 09:07:47 EDT
Verified on ER2
Comment 10 carlo.tomei 2013-11-22 05:57:47 EST
Hi Everybody,

I downloaded overlord-rtgov-jbossas-1.0.0.Final yesterday and aftern the installation on a local instance of EAP 6.1.0(standalone-all.xml) i'm still experiencing the problems up on reported:
1. i had to move all the installed modules under the base.
2. JBAS018759: Failed to load module: deployment.overlord-rtgov.war:main
   Caused by: org.jboss.modules.ModuleNotFoundException: org.switchyard.bus.camel:main
3.  Failed to obtain reference to ActiveCollectionManager
    Caused by: java.lang.IllegalStateException: JBAS011048: Failed to construct component instanc
4. 11:29:40,564 SEVERE [org.overlord.rtgov.internal.epn.loader.jee.JEEEPNLoader] (ServerService Thread Pool -- 60) Failed to obtain reference to EPNManager

11:29:41,258 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report
JBAS014777:   Services which failed to start:      service jboss.deployment.unit."overlord-rtgov-epn.war".component.JEEEPNLoader.START: org.jboss.msc.service.StartException in service jboss.deployment.unit."overlord-rtgov-epn.war".component.JEEEPNLoader.START: java.lang.IllegalStateException: JBAS011048: Failed to construct component instance
      service jboss.deployment.unit."overlord-rtgov-acs.war".component.JEEACSLoader.START: org.jboss.msc.service.StartException in service jboss.deployment.unit."overlord-rtgov-acs.war".component.JEEACSLoader.START: java.lang.IllegalStateException: JBAS011048: Failed to construct component instance
      service jboss.module.service."deployment.overlord-rtgov.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.overlord-rtgov.war".main: JBAS018759: Failed to load module: deployment.overlord-rtgov.war:main


Can Anyone Help?

Carlo
Comment 11 Gary Brown 2013-11-22 06:03:49 EST
Hi Carlo

Questions regarding community versions should be asked on the Overlord user forum: https://community.jboss.org/en/overlord with issues raised on the project jira: http://www.jboss.org/overlord/issues/rtgov

Version 1.0.0.Final is dependent upon switchyard. The next community release will fix this issue - however this may not be for a couple of months. If you require a release earlier, then you will need to build rtgov, gadget-server and overlord-commons projects from source.

Regards
Gary
Comment 12 carlo.tomei 2013-11-22 06:06:08 EST
Everything clear,

Thank you Gary.
Comment 13 JBoss JIRA Server 2014-07-02 05:19:49 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-261 to Closed

Note You need to log in before you can comment on or make changes to this bug.