Bug 1003999 - [RFE] Need ability to filter which packages get synced from source
[RFE] Need ability to filter which packages get synced from source
Status: CLOSED DUPLICATE of bug 754576
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks: 1004001
  Show dependency treegraph
 
Reported: 2013-09-03 12:56 EDT by Mike McCune
Modified: 2015-12-03 10:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1004001 (view as bug list)
Environment:
Last Closed: 2015-10-08 15:58:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-09-03 12:56:48 EDT
Filtering in pulp currently only effects published Content Views but there is no way to apply a filtering algorithm to a yum repository feed.

There are often cases where repositories contain large sets of packages that are never used (architectures, subdirectories, etc), eg:

http://linux.dell.com/repo/hardware/latest/platform_independent/rh60_64/

where the user may only want a certain subset of the large repo.

The customer should have the ability to specify on the repo a set of filters which prevent packages from being synced thus saving disk space and sync time.
Comment 1 Michael Hrivnak 2013-09-04 11:16:14 EDT
I'm interested in thoughts on how this might work. I imagine that some sort of regex matching on the "name" could get us a lot of the way. The question is, how many regexs is it going to take?

Are we interested in a scenario like the dell repo where there are tons of RPMs, but we only want a few?

Is it sufficient to do a default-none when one or more filters are present, so that the user must match the packages to get? Or do we need the ability to exclude matched packages?

Either way, this is only likely to be useful in cases where the user can make a small number of filters in a simple way to get the behavior they want. Thoughts?
Comment 2 RHEL Product and Program Management 2013-09-17 00:16:02 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 7 Bryan Kearney 2015-10-08 15:58:28 EDT

*** This bug has been marked as a duplicate of bug 754576 ***

Note You need to log in before you can comment on or make changes to this bug.