Bug 1004002 - [AMQP 1.0] AmqpValue sections of type string are not handled correctly
[AMQP 1.0] AmqpValue sections of type string are not handled correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
medium Severity unspecified
: 3.0
: ---
Assigned To: Gordon Sim
Ernie
: OtherQA
Depends On:
Blocks: 1010399
  Show dependency treegraph
 
Reported: 2013-09-03 13:03 EDT by Gordon Sim
Modified: 2015-01-21 07:56 EST (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:56:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-5040 None None None Never

  None (edit)
Description Gordon Sim 2013-09-03 13:03:30 EDT
Description of problem:

When using qpid::messaging to receive messages whose content is encoded as a string valued AmqpValue section (e.g. as sent by proton messenger examples), the content is not made available to application.

Version-Release number of selected component (if applicable):

qpid-cpp-0.22-11 (caused by changes for https://bugzilla.redhat.com/show_bug.cgi?id=996573)

How reproducible:

100%

Steps to Reproduce:
1. send message using proton messenger send example to a queue on a broker
2. receive that message using qpid::messaging (e.g. drain or qpid-receive)

Actual results:

Content reported as null/void

Expected results:

Content received as sent

Additional info:
Comment 1 Gordon Sim 2013-09-03 13:05:15 EDT
Fixed upstream: https://svn.apache.org/r1518955
Comment 2 Ernie 2014-03-25 16:31:00 EDT
This issue has been fixed. Verified on rhel6.5 (x86_64, i386).

string content sent using proton to drain or qpid-receive with protocol:amqp1.0 is received properly

packages under test:
qpid-cpp-*-0.22-35

Note You need to log in before you can comment on or make changes to this bug.