Bug 1004003 - Packstack requires Python packages not available in RHEL6
Packstack requires Python packages not available in RHEL6
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 13:03 EDT by Martina Kollarova
Modified: 2016-04-26 09:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 13:36:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martina Kollarova 2013-09-03 13:03:57 EDT
Description of problem:
Running the latest RDO/Havana Packstack requires packages that are not available yet - python-amqplib, python-kombu and python-pbr.

Version-Release number of selected component (if applicable):
RHEL 6.4,
latest RDO havana (http://repos.fedorapeople.org/repos/openstack/openstack-havana/),
openstack-packstack-2013.2.1-0.4.dev740.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. use this repo http://repos.fedorapeople.org/repos/openstack/openstack-havana/
2. install openstack-packstack
3. run packstack --allinone

Actual results:
Error: Package: python-nova-2013.2-0.8.b2.el6.noarch (openstack-havana)
           Requires: python-amqplib
Error: Package: python-nova-2013.2-0.8.b2.el6.noarch (openstack-havana)
           Requires: python-kombu
Error: Package: python-neutron-2013.2-0.3.b2.el6.noarch (openstack-havana)
           Requires: python-kombu
Error: Package: openstack-neutron-2013.2-0.3.b2.el6.noarch (openstack-havana)
           Requires: python-pbr
Error: Package: python-neutron-2013.2-0.3.b2.el6.noarch (openstack-havana)
           Requires: python-amqplib

Expected results:
RDO installed

Additional info:
Comment 1 Perry Myers 2013-09-03 13:25:18 EDT
RDO requires EPEL to function.  Packstack in RDO enables EPEL by default.  The above packages are available in EPEL

python-amqplib.noarch   0.6.1-2.el6
python-kombu.noarch     1.1.3-1.el6                                              
python-pbr.noarch       0.5.19-2.el6

@mmagr, is Packstack not enabling EPEL properly?

@mkollaro, can you confirm that packstack put a file in /etc/yum.repos.d/epel.repo into place and that repo is enabled?

What do you get if you do:

sudo yum list python-kombu --enablerepo=epel ?
Comment 2 Martina Kollarova 2013-09-03 13:36:43 EDT
Alright, I found the culprit. The epel repo was enabled, but there was a whitelist of packages that can be used from it (since we shouldn't be using epel for upstream tests, this pre-build image already had this whitelist). Sorry I didn't notice this, it looked enabled.

Note You need to log in before you can comment on or make changes to this bug.