Bug 1004015 - iSNS discovery support through offloaded ifaces [NEEDINFO]
iSNS discovery support through offloaded ifaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.5
x86_64 Linux
high Severity urgent
: rc
: ---
Assigned To: Chris Leech
Martin Hoyer
: Patch, ZStream
Depends On:
Blocks: 1269194 1360897 1400664 1405173 1365614 1365615
  Show dependency treegraph
 
Reported: 2013-09-03 13:34 EDT by john soni jose
Modified: 2017-03-21 06:32 EDT (History)
17 users (show)

See Also:
Fixed In Version: iscsi-initiator-utils-6.2.0.873-22.el6
Doc Type: Bug Fix
Doc Text:
Discovery of iSCSI storage targets using the Internet Storage Name Service (iSNS) protocol did not properly bind the discovered target portal to offloading iSCSI Host Bus Adapter (HBA) interfaces. As a consequence, iSNS discovery failed when performed by offloading iSCSI HBAs. With this update, iSNS binds the target portal as expected, and thus ensures that offloading iSCSI HBAs enables iSNS discovery.
Story Points: ---
Clone Of:
: 1365614 1365615 (view as bug list)
Environment:
Last Closed: 2017-03-21 06:32:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nkshirsa: needinfo? (cleech)


Attachments (Terms of Use)
iSNS discovery fix patch. (6.10 KB, application/mbox)
2013-09-03 13:34 EDT, john soni jose
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2600161 None None None 2016-09-03 11:24 EDT

  None (edit)
Description john soni jose 2013-09-03 13:34:02 EDT
Created attachment 793317 [details]
iSNS discovery fix patch.

Description of problem:
iSNS discovery throught offload ifaces fails with the current iscsiadm.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. do iSNS discovery through one of the offloaded interfaces.
2.
3.

Actual results:
The iSNS discovery fails with the message
"iscsiadm: iface be2iscsi.00:90:fa:30:1b:81.ipv4.0 is not valid. Will not bind node to it. Iface settings [hw=,ip=,net_if=,iscsi_if=be2iscsi.00:90:fa:30:1b:81.ipv4.0]
iscsiadm: No portals found"


Expected results:
The target should be shown as o/p

Additional info:
The patch which fixes this issue has recently been added to the open-iscsi-github. Attaching the patch also.
Comment 2 RHEL Product and Program Management 2013-10-13 22:24:22 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 21 Martin Hoyer 2016-12-22 07:50:12 EST
Works well with iscsi-initiator-utils-6.2.0.873-22.el6. Regression tests did not found any new issue.
Comment 23 errata-xmlrpc 2017-03-21 06:32:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0679.html

Note You need to log in before you can comment on or make changes to this bug.